dev-python/subunit: Add pypy3 support
authorJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 06:39:01 +0000 (08:39 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:12:09 +0000 (12:12 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/subunit/subunit-0.0.10-r1.ebuild
dev-python/subunit/subunit-1.1.0.ebuild

index 77a525a42f4f3bb7fbb02461d1c32a63c9fee304..efb909281b73896272211ac29f0e94da69d9ae80 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
+PYTHON_COMPAT=( python{2_7,3_3} pypy pypy3 )
 
 inherit autotools-utils python-single-r1
 
index 67a737edf288a7986eba11608bfc7ef6044b507b..92e1f3f8a69a0295b374717aeeea795389b98b31 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
 
 inherit distutils-r1 eutils multilib-minimal
 
@@ -17,7 +17,8 @@ SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
 IUSE="static-libs test"
 
-RDEPEND=">=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+RDEPEND="
+       >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
        dev-python/extras[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]