net-libs/gnutls: support cross-compile
authorAlon Bar-Lev <alonbl@gentoo.org>
Fri, 5 Oct 2018 23:27:50 +0000 (02:27 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sat, 6 Oct 2018 00:32:18 +0000 (03:32 +0300)
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.10

net-libs/gnutls/gnutls-3.5.19-r1.ebuild
net-libs/gnutls/gnutls-3.6.3.ebuild

index 1635d976bdf44b57a9fbb1a69316c1d3c14985c0..21b4a74b0dc188afda4bd51eeac4c154baa70d18 100644 (file)
@@ -34,11 +34,11 @@ DEPEND="${RDEPEND}
        test? (
                seccomp? ( sys-libs/libseccomp )
        )"
-BDEPEND=">=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
-       tools? ( sys-devel/autogen )
-       valgrind? ( dev-util/valgrind )
+BDEPEND=">=virtual/pkgconfig-0-r1
        doc? ( dev-util/gtk-doc )
        nls? ( sys-devel/gettext )
+       tools? ( sys-devel/autogen )
+       valgrind? ( dev-util/valgrind )
        test-full? (
                app-crypt/dieharder
                app-misc/datefudge
@@ -79,10 +79,6 @@ src_prepare() {
 multilib_src_configure() {
        LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
 
-       # remove magic of library detection
-       # bug#438222
-       local libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
-
        # TPM needs to be tested before being enabled
        libconf+=( --without-tpm )
 
@@ -117,9 +113,11 @@ multilib_src_configure() {
                $(use_with idn) \
                $(use_with pkcs11 p11-kit) \
                $(use_with zlib) \
+               --disable-rpath \
                --with-unbound-root-key-file="${EPREFIX}/etc/dnssec/root-anchors.txt" \
                --without-included-libtasn1 \
-               "${libconf[@]}"
+               "${libconf[@]}" \
+               $("${S}/configure" --help | grep -- --with-.*-prefix | sed -e 's/prefix.*/prefix/' -e "s#\$#=${EROOT}/usr#")
 }
 
 multilib_src_install_all() {
index fefc8766f6af5f37d634b76cfe52cd48707c6d28..92679e621dc4fee60baada6dce0701f893203236 100644 (file)
@@ -33,11 +33,11 @@ DEPEND="${RDEPEND}
        test? (
                seccomp? ( sys-libs/libseccomp )
        )"
-BDEPEND=">=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
-       tools? ( sys-devel/autogen )
-       valgrind? ( dev-util/valgrind )
+BDEPEND=">=virtual/pkgconfig-0-r1
        doc? ( dev-util/gtk-doc )
        nls? ( sys-devel/gettext )
+       tools? ( sys-devel/autogen )
+       valgrind? ( dev-util/valgrind )
        test-full? (
                app-crypt/dieharder
                >=app-misc/datefudge-1.22
@@ -78,10 +78,6 @@ src_prepare() {
 multilib_src_configure() {
        LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
 
-       # remove magic of library detection
-       # bug#438222
-       local libconf=($("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g'))
-
        # TPM needs to be tested before being enabled
        libconf+=( --without-tpm )
 
@@ -113,9 +109,11 @@ multilib_src_configure() {
                $(use_enable tls-heartbeat heartbeat-support) \
                $(use_with idn) \
                $(use_with pkcs11 p11-kit) \
+               --disable-rpath \
                --with-unbound-root-key-file="${EPREFIX}/etc/dnssec/root-anchors.txt" \
                --without-included-libtasn1 \
-               "${libconf[@]}"
+               "${libconf[@]}" \
+               $("${S}/configure" --help | grep -- --with-.*-prefix | sed -e 's/prefix.*/prefix/' -e "s#\$#=${EROOT}/usr#")
 }
 
 multilib_src_install_all() {