sys-boot/grub: new snapshot 2.05_alpha20200310
authorMike Gilbert <floppym@gentoo.org>
Sun, 15 Mar 2020 18:29:59 +0000 (14:29 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sun, 15 Mar 2020 18:34:44 +0000 (14:34 -0400)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sys-boot/grub/Manifest
sys-boot/grub/grub-2.05_alpha20200310.ebuild [new file with mode: 0644]

index 46884c72bb2a57b961d11af62f77a63dc13d99cb..6493cd098a85bcec68f8b0bc8e01bab2a5872a4d 100644 (file)
@@ -3,5 +3,6 @@ DIST grub-2.02.tar.xz 6113260 BLAKE2B 7c5ec61a8dc5a00e9cdc91c489f0d2ee37cd7e673e
 DIST grub-2.04.tar.xz 6393864 BLAKE2B 413ffb9aaeae1ee3128032914ca426a1a5adb3737895dfe563fdde5a7e0386ac2dbc2f7ddfc4e0a67b3ad90494985d6886c20054b038701feb743e67e2eed9d0 SHA512 9c15c42d0cf5d61446b752194e3b628bb04be0fe6ea0240ab62b3d753784712744846e1f7c3651d8e0968d22012e6d713c38c44936d4004ded3ca4d4007babbb
 DIST grub-2.05_alpha20200110.tar.xz 5452588 BLAKE2B ccf95644bc76f6be8e73a25e1b5f05e052ea5bc0c61896454c211fccaec6a714dbae10f7398aa1e9d7bf864efc68655708c102ba20cc1e40fecd3fa7d3d961f7 SHA512 b6e609edc4dcee5d9348d1d6d9ecfec5a759a284a1f82970b38f8aab0c8fa6b5dc69e532a1a264815208df5dae3bf409c2f73846893a8e3cb97187d0e0c7295c
 DIST grub-2.05_alpha20200228.tar.xz 6619176 BLAKE2B 15f45495bfffab71f9e4bccd0c60b48dcedfec7da650ceb3bc66f64ad7331e8ab1f786d04893d81b6c2e61dab6fa1ff47a29afcaa7f92bb478c4b18312311604 SHA512 28e42b0125283d0ef3d415a69699416e83e3ee32d60ffe092b0d03765d150579bd3fb218ed2bbf4877bd802012b409a502e86e825c0d22265252097d20449957
+DIST grub-2.05_alpha20200310.tar.xz 6671372 BLAKE2B 2b9006fe486bb3195f34a3e5d34eaa923e1f295fbb7b815b0adf70ca3000531ff0c250c300f21103cf24144f9e51b96cefc860b7a46c6e31b96d4566db08b027 SHA512 7ddcb7524a4fa60754e3053aae4b033b17ffd740f220d3cbc1e25167ce823c42b1795b4767dabb8920027134769de8cacdafc9a6fe26b4d242590809e3db8725
 DIST unifont-12.1.02.pcf.gz 1335424 BLAKE2B 97080312468e3f3c8aa6f49cef08f5622641e8c9c035f3ede1e09d8d98de4e78d3b23c8aba2e8070eb46cbebd2d55e8568e467d7f15f35aa8fc8db792b7e5f14 SHA512 b280b2db7cf5f480b0668c331130dede2c0cc87d5e02e44566b77787113d0f6604d0105522858288f2ac6b8e77df7a2d9878725013a6c778dc5bfb183156e2f0
 DIST unifont-9.0.06.pcf.gz 1360354 BLAKE2B 09b96e1711c729ef159d62e3ea7b289ca2d01dc0ea417e35a18b73dc02a23f62ce7821d9761bceee4002d9eeaabd91cfb69bbacc6fbdfdfa00445d18fe8f1d66 SHA512 dd0a1afa72f5204c62055d83f22750c74af38ffafdb8eda8e1f1cf7292e572a14969b8a9a6a2cb336d5bed4ab633f6b5a962c59117a590e4238788959cb82774
diff --git a/sys-boot/grub/grub-2.05_alpha20200310.ebuild b/sys-boot/grub/grub-2.05_alpha20200310.ebuild
new file mode 100644 (file)
index 0000000..d11a7ec
--- /dev/null
@@ -0,0 +1,287 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999  ]]; then
+       GRUB_AUTORECONF=1
+       GRUB_BOOTSTRAP=1
+fi
+
+if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
+       PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+       inherit python-any-r1
+fi
+
+if [[ -n ${GRUB_AUTORECONF} ]]; then
+       WANT_LIBTOOL=none
+       inherit autotools
+fi
+
+inherit bash-completion-r1 eutils flag-o-matic multibuild pax-utils toolchain-funcs
+
+if [[ ${PV} != 9999 ]]; then
+       SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+else
+       inherit git-r3
+       EGIT_REPO_URI="https://git.savannah.gnu.org/git/grub.git"
+fi
+
+PATCHES=(
+       "${FILESDIR}"/gfxpayload.patch
+       "${FILESDIR}"/grub-2.02_beta2-KERNEL_GLOBS.patch
+)
+
+DEJAVU=dejavu-sans-ttf-2.37
+UNIFONT=unifont-12.1.02
+SRC_URI+=" fonts? ( mirror://gnu/unifont/${UNIFONT}/${UNIFONT}.pcf.gz )
+       themes? ( mirror://sourceforge/dejavu/${DEJAVU}.zip )"
+
+DESCRIPTION="GNU GRUB boot loader"
+HOMEPAGE="https://www.gnu.org/software/grub/"
+
+# Includes licenses for dejavu and unifont
+LICENSE="GPL-3+ BSD MIT fonts? ( GPL-2-with-font-exception ) themes? ( CC-BY-SA-3.0 BitstreamVera )"
+SLOT="2/${PVR}"
+IUSE="device-mapper doc efiemu +fonts mount nls sdl test +themes truetype libzfs"
+
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 xen-pvh )
+IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
+
+REQUIRED_USE="
+       grub_platforms_coreboot? ( fonts )
+       grub_platforms_qemu? ( fonts )
+       grub_platforms_ieee1275? ( fonts )
+       grub_platforms_loongson? ( fonts )
+"
+
+BDEPEND="
+       ${PYTHON_DEPS}
+       app-misc/pax-utils
+       sys-devel/flex
+       sys-devel/bison
+       sys-apps/help2man
+       sys-apps/texinfo
+       fonts? (
+               media-libs/freetype:2
+               virtual/pkgconfig
+       )
+       test? (
+               app-admin/genromfs
+               app-arch/cpio
+               app-arch/lzop
+               app-emulation/qemu
+               dev-libs/libisoburn
+               sys-apps/miscfiles
+               sys-block/parted
+               sys-fs/squashfs-tools
+       )
+       themes? (
+               app-arch/unzip
+               media-libs/freetype:2
+               virtual/pkgconfig
+       )
+       truetype? ( virtual/pkgconfig )
+"
+DEPEND="
+       app-arch/xz-utils
+       >=sys-libs/ncurses-5.2-r5:0=
+       sdl? ( media-libs/libsdl )
+       device-mapper? ( >=sys-fs/lvm2-2.02.45 )
+       libzfs? ( sys-fs/zfs )
+       mount? ( sys-fs/fuse:0 )
+       truetype? ( media-libs/freetype:2= )
+       ppc? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
+       ppc64? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
+"
+RDEPEND="${DEPEND}
+       kernel_linux? (
+               grub_platforms_efi-32? ( sys-boot/efibootmgr )
+               grub_platforms_efi-64? ( sys-boot/efibootmgr )
+       )
+       !sys-boot/grub:0 !sys-boot/grub-static
+       nls? ( sys-devel/gettext )
+"
+
+RESTRICT="!test? ( test )"
+
+QA_EXECSTACK="usr/bin/grub-emu* usr/lib/grub/*"
+QA_PRESTRIPPED="usr/lib/grub/.*"
+QA_MULTILIB_PATHS="usr/lib/grub/.*"
+QA_WX_LOAD="usr/lib/grub/*"
+
+src_unpack() {
+       if [[ ${PV} == 9999 ]]; then
+               git-r3_src_unpack
+               pushd "${P}" >/dev/null || die
+               local GNULIB_URI="https://git.savannah.gnu.org/git/gnulib.git"
+               local GNULIB_REVISION=$(source bootstrap.conf >/dev/null; echo "${GNULIB_REVISION}")
+               git-r3_fetch "${GNULIB_URI}" "${GNULIB_REVISION}"
+               git-r3_checkout "${GNULIB_URI}" gnulib
+               popd >/dev/null || die
+       fi
+       default
+}
+
+src_prepare() {
+       default
+
+       sed -i -e /autoreconf/d autogen.sh || die
+
+       # Nothing in Gentoo packages 'american-english' in the exact path
+       # wanted for the test, but all that is needed is a compressible text
+       # file, and we do have 'words' from miscfiles in the same path.
+       sed -i \
+               -e '/CFILESSRC.*=/s,american-english,words,' \
+               tests/util/grub-fs-tester.in \
+               || die
+
+       if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
+               python_setup
+       fi
+
+       if [[ -n ${GRUB_BOOTSTRAP} ]]; then
+               eautopoint --force
+               AUTOPOINT=: AUTORECONF=: ./bootstrap || die
+       elif [[ -n ${GRUB_AUTOGEN} ]]; then
+               ./autogen.sh || die
+       fi
+
+       if [[ -n ${GRUB_AUTORECONF} ]]; then
+               eautoreconf
+       fi
+}
+
+grub_do() {
+       multibuild_foreach_variant run_in_build_dir "$@"
+}
+
+grub_do_once() {
+       multibuild_for_best_variant run_in_build_dir "$@"
+}
+
+grub_configure() {
+       local platform
+
+       case ${MULTIBUILD_VARIANT} in
+               efi*) platform=efi ;;
+               xen-pvh) platform=xen_pvh ;;
+               xen*) platform=xen ;;
+               guessed) ;;
+               *) platform=${MULTIBUILD_VARIANT} ;;
+       esac
+
+       case ${MULTIBUILD_VARIANT} in
+               *-32)
+                       if [[ ${CTARGET:-${CHOST}} == x86_64* ]]; then
+                               local CTARGET=i386
+                       fi ;;
+               *-64)
+                       if [[ ${CTARGET:-${CHOST}} == i?86* ]]; then
+                               local CTARGET=x86_64
+                               local -x TARGET_CFLAGS="-Os -march=x86-64 ${TARGET_CFLAGS}"
+                               local -x TARGET_CPPFLAGS="-march=x86-64 ${TARGET_CPPFLAGS}"
+                       fi ;;
+       esac
+
+       local myeconfargs=(
+               --disable-werror
+               --program-prefix=
+               --libdir="${EPREFIX}"/usr/lib
+               $(use_enable device-mapper)
+               $(use_enable mount grub-mount)
+               $(use_enable nls)
+               $(use_enable themes grub-themes)
+               $(use_enable truetype grub-mkfont)
+               $(use_enable libzfs)
+               $(use_enable sdl grub-emu-sdl)
+               ${platform:+--with-platform=}${platform}
+
+               # Let configure detect this where supported
+               $(usex efiemu '' '--disable-efiemu')
+       )
+
+       if use fonts; then
+               ln -rs "${WORKDIR}/${UNIFONT}.pcf" unifont.pcf || die
+       fi
+
+       if use themes; then
+               ln -rs "${WORKDIR}/${DEJAVU}/ttf/DejaVuSans.ttf" DejaVuSans.ttf || die
+       fi
+
+       local ECONF_SOURCE="${S}"
+       econf "${myeconfargs[@]}"
+}
+
+src_configure() {
+       # Bug 508758.
+       replace-flags -O3 -O2
+
+       # We don't want to leak flags onto boot code.
+       export HOST_CCASFLAGS=${CCASFLAGS}
+       export HOST_CFLAGS=${CFLAGS}
+       export HOST_CPPFLAGS=${CPPFLAGS}
+       export HOST_LDFLAGS=${LDFLAGS}
+       unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
+
+       tc-ld-disable-gold #439082 #466536 #526348
+       export TARGET_LDFLAGS="${TARGET_LDFLAGS} ${LDFLAGS}"
+       unset LDFLAGS
+
+       tc-export CC NM OBJCOPY RANLIB STRIP
+       tc-export BUILD_CC # Bug 485592
+
+       MULTIBUILD_VARIANTS=()
+       local p
+       for p in "${GRUB_ALL_PLATFORMS[@]}"; do
+               use "grub_platforms_${p}" && MULTIBUILD_VARIANTS+=( "${p}" )
+       done
+       [[ ${#MULTIBUILD_VARIANTS[@]} -eq 0 ]] && MULTIBUILD_VARIANTS=( guessed )
+       grub_do grub_configure
+}
+
+src_compile() {
+       # Sandbox bug 404013.
+       use libzfs && addpredict /etc/dfs:/dev/zfs
+
+       grub_do emake
+       use doc && grub_do_once emake -C docs html
+}
+
+src_test() {
+       # The qemu dependency is a bit complex.
+       # You will need to adjust QEMU_SOFTMMU_TARGETS to match the cpu/platform.
+       grub_do emake check
+}
+
+src_install() {
+       grub_do emake install DESTDIR="${D}" bashcompletiondir="$(get_bashcompdir)"
+       use doc && grub_do_once emake -C docs install-html DESTDIR="${D}"
+
+       einstalldocs
+
+       insinto /etc/default
+       newins "${FILESDIR}"/grub.default-3 grub
+
+       # https://bugs.gentoo.org/231935
+       dostrip -x /usr/lib/grub
+}
+
+pkg_postinst() {
+       elog "For information on how to configure GRUB2 please refer to the guide:"
+       elog "    https://wiki.gentoo.org/wiki/GRUB2_Quick_Start"
+
+       if has_version 'sys-boot/grub:0'; then
+               elog "A migration guide for GRUB Legacy users is available:"
+               elog "    https://wiki.gentoo.org/wiki/GRUB2_Migration"
+       fi
+
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               elog
+               elog "You may consider installing the following optional packages:"
+               optfeature "Detect other operating systems (grub-mkconfig)" sys-boot/os-prober
+               optfeature "Create rescue media (grub-mkrescue)" dev-libs/libisoburn
+               optfeature "Enable RAID device detection" sys-fs/mdadm
+       fi
+}