dev-lang/mercury: version bump
authorKeri Harris <keri@gentoo.org>
Wed, 1 Apr 2020 10:31:05 +0000 (12:31 +0200)
committerKeri Harris <keri@gentoo.org>
Wed, 1 Apr 2020 10:31:52 +0000 (12:31 +0200)
Signed-off-by: Keri Harris <keri@gentoo.org>
Package-Manager: Portage-2.3.89, Repoman-2.3.11

dev-lang/mercury/Manifest
dev-lang/mercury/mercury-20.01.1.ebuild [new file with mode: 0644]

index 358ce03909af9855b071e47ea1792f796d21771d..728f4bebfb42e2e3125c89b0c4ee48f5416f86fc 100644 (file)
@@ -1,4 +1,6 @@
 DIST mercury-14.01.1-gentoo-patchset-5.tar.gz 5693 BLAKE2B 300de3254bc0d2f59493c0e2243b0d8786fccce714134a11ce510120b7d9f05ebe4835f084ec2db2ddaf2d405cbae65e86d809847079a7d63a6a68021d9d29e8 SHA512 3f9f1e2359f372e4f510b9a00c197978657b28d1308d12cba4d08a982877e2311d7fb6e626dad07d0fa09d24f97334575557cb49003508fdc7b32288c1ae8f2d
 DIST mercury-20.01-gentoo-patchset-0.tar.gz 3862 BLAKE2B 79ef6d30add63a5d419e3dd5b376fd9c1727038102db2bc0e8ccd8b71cdc1c80e721647f34764b0aa4fd6d58b9e38c9675f234714f381f94be572b9b64b478e1 SHA512 2835b4740453bcc358363f9eaa0264706125b5e5f7a38802d5f280ccd777d4c760124ed3a635f17ecc2ae772767e9fa5d61093c40094358a0a96a726a23ff08e
+DIST mercury-20.01.1-gentoo-patchset-0.tar.gz 3943 BLAKE2B 0fd149c622715bf191182bd93e264096327d7869e30aaa10bb19b70bec5563520026e2561cc6607c62801ed00ed6b5907bbae4be997869b9facb2f9d65ec0c7a SHA512 d866b35b6df14645ef60ff25497f9bbf0c2caeae2145bc0aef2adea0e651379c673c1815c717f1a51457d93cc67e9ae3dafe5d9fce1d4734bf1673e4cfcbd367
 DIST mercury-srcdist-14.01.1.tar.gz 52658945 BLAKE2B 6497921a0227b9a6fbcbabdd309ef3325f32dda14fc4ddb443368385b89be4011d677a24b30b3702147d1b782fe2597760ad66dd34503aa6aebaf79707466529 SHA512 a128ef0fd4955abadea32019ec59297ffe32537415f32e9e948cbc1c3439bb40eb09de77569690fb18dd7d6969a2b1141b3ae5baeb87f2627eaa65ad93add92c
+DIST mercury-srcdist-20.01.1.tar.gz 47088335 BLAKE2B 1e3285dadc3748934e801b8ac0316d3005fbe24c20c9ceb694e9fc316d820fdb89c659107b25ee474fd6ac50d661dd029af9ca5082016a3b0827dd640a54a707 SHA512 24ad0bbecee46ab6ff669d63d64096b37a0d010bb44978a1785eee2701a8b30a83eab229af97cbbb18bca55b5e89be9ba74fe126d1d430da1e1e909366dc5b90
 DIST mercury-srcdist-20.01.tar.gz 47103868 BLAKE2B 68be786e925bdf94dcba6c6a2a746a384da345ee33250785d8d2b9281815694a4525cdd694c26f58051c097f2a897291e640e2139729ccede9bd2e472077d8c9 SHA512 90e36faa375603e596b2dd692363528120fda62ae6d2e2b119cf76de1656dae4028aff00858a4bff3fdfb9b2210ea17db0aa516ce4283604c46a5935dd2cd4b7
diff --git a/dev-lang/mercury/mercury-20.01.1.ebuild b/dev-lang/mercury/mercury-20.01.1.ebuild
new file mode 100644 (file)
index 0000000..6770d42
--- /dev/null
@@ -0,0 +1,201 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common eutils flag-o-matic java-pkg-opt-2 multilib vcs-clean xdg-utils
+
+PATCHSET_VER="0"
+MY_P=${PN}-srcdist-${PV}
+
+DESCRIPTION="Mercury is a modern general-purpose logic/functional programming language"
+HOMEPAGE="http://www.mercurylang.org/index.html"
+SRC_URI="http://dl.mercurylang.org/release/${MY_P}.tar.gz
+       mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug doc emacs erlang examples java mono profile readline threads trail"
+
+DEPEND="net-libs/libnsl:0=
+       readline? ( sys-libs/readline:= )
+       erlang? ( dev-lang/erlang )
+       java? ( >=virtual/jdk-1.6:= )
+       mono? ( dev-lang/mono )
+       doc? ( sys-apps/texinfo )"
+
+RDEPEND="${DEPEND}
+       emacs? ( >=app-editors/emacs-23.1:* )"
+
+S="${WORKDIR}"/${MY_P}
+
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare() {
+       if [[ -d "${WORKDIR}"/${PV} ]] ; then
+               eapply "${WORKDIR}"/${PV}
+       fi
+       eapply_user
+
+       AT_M4DIR=m4 eautoreconf
+
+       xdg_environment_reset
+}
+
+src_configure() {
+       strip-flags
+
+       local myconf
+       myconf="--libdir=/usr/$(get_libdir) \
+               $(use_enable mono csharp-grade) \
+               $(use_enable erlang erlang-grade) \
+               $(use_enable java java-grade) \
+               $(use_enable debug debug-grades) \
+               $(use_enable profile prof-grades) \
+               $(use_enable threads par-grades) \
+               $(use_enable trail trail-grades) \
+               $(use_with readline)"
+
+       econf ${myconf}
+}
+
+src_compile() {
+       # Prepare mmake flags
+       echo "EXTRA_CFLAGS  = ${CFLAGS}"  >> Mmake.params
+       echo "EXTRA_LD_LIBFLAGS = ${LDFLAGS}" >> Mmake.params
+       echo "EXTRA_MLFLAGS = --no-strip" >> Mmake.params
+
+       echo "EXTRA_LD_LIBFLAGS += -Wl,-soname=libgc.so" >> boehm_gc/Mmake.boehm_gc.params
+       echo "EXTRA_LD_LIBFLAGS += -Wl,-soname=libmer_rt.so" >> runtime/Mmake.runtime.params
+       echo "EXTRA_LD_LIBFLAGS += -Wl,-soname=libmer_std.so" >> library/Mmake.library.params
+
+       # Build Mercury using bootstrap grade
+       emake \
+               PARALLEL="'${MAKEOPTS}'" \
+               TEXI2DVI="" PDFTEX=""
+
+       # We can now patch .m Mercury compiler files since we
+       # have just built mercury_compiler.
+       if [[ -d "${WORKDIR}"/${PV}-mmc ]] ; then
+               eapply "${WORKDIR}"/${PV}-mmc
+       fi
+
+       # Rebuild Mercury compiler using the just built mercury_compiler
+       emake \
+               PARALLEL="'${MAKEOPTS}'" \
+               MERCURY_COMPILER="${S}"/compiler/mercury_compile \
+               TEXI2DVI="" PDFTEX=""
+
+       # The default Mercury grade may not be the same as the bootstrap
+       # grade. Since src_test() is run before src_install() we compile
+       # the default grade now
+       emake \
+               PARALLEL="'${MAKEOPTS}'" \
+               MERCURY_COMPILER="${S}"/compiler/mercury_compile \
+               TEXI2DVI="" PDFTEX="" \
+               default_grade
+}
+
+src_test() {
+       TEST_GRADE=$(scripts/ml --print-grade)
+       if [ -d "${S}"/install_grade_dir.${TEST_GRADE} ] ; then
+               TWS="${S}"/install_grade_dir.${TEST_GRADE}
+               cp runtime/mer_rt.init "${TWS}"/runtime/
+               cp mdbcomp/mer_mdbcomp.init "${TWS}"/mdbcomp/
+               cp browser/mer_browser.init "${TWS}"/browser/
+       else
+               TWS="${S}"
+       fi
+
+       cd "${S}"/tests || die
+       sed -e "s:@WORKSPACE@:${TWS}:" \
+               < WS_FLAGS.ws \
+               > WS_FLAGS \
+               || die "sed WORKSPACE failed"
+       sed -e "s:@WORKSPACE@:${TWS}:" \
+               < .mgnuc_copts.ws \
+               > .mgnuc_copts \
+               || die "sed WORKSPACE failed"
+       find . -mindepth 1 -type d -exec cp .mgnuc_opts  {} \;
+       find . -mindepth 1 -type d -exec cp .mgnuc_copts {} \;
+
+       # Mercury tests must be run in C locale since Mercury output is
+       # compared to hard-coded warnings/errors
+       LC_ALL="C" \
+       PATH="${TWS}"/scripts:"${TWS}"/util:"${S}"/slice:"${PATH}" \
+       TERM="" \
+       WORKSPACE="${TWS}" \
+       WORKSPACE_FLAGS=yes \
+       MERCURY_COMPILER="${TWS}"/compiler/mercury_compile \
+       MMAKE_DIR="${TWS}"/scripts \
+       MERCURY_SUPPRESS_STACK_TRACE=yes \
+       GRADE=${TEST_GRADE} \
+               mmake || die "mmake test failed"
+}
+
+src_install() {
+       emake \
+               PARALLEL="'${MAKEOPTS}'" \
+               MERCURY_COMPILER="${S}"/compiler/mercury_compile \
+               TEXI2DVI="" PDFTEX="" \
+               DESTDIR="${D}" \
+               INSTALL_ELISP_DIR="${D}/${SITELISP}"/${PN} \
+               install
+
+       if use java; then
+               keepdir /usr/$(get_libdir)/mercury/modules/java
+       fi
+
+       if use mono; then
+               keepdir /usr/$(get_libdir)/mercury/modules/csharp
+       fi
+
+       if use emacs; then
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+                       || die "elisp-site-file-install failed"
+       fi
+
+       dodoc \
+               BUGS HISTORY LIMITATIONS NEWS README README.Linux \
+               README.Linux-Alpha README.Linux-m68k README.Linux-PPC \
+               RELEASE_NOTES VERSION || die
+
+       if use erlang; then
+               dodoc README.Erlang
+       fi
+
+       if use java; then
+               dodoc README.Java
+       fi
+
+       if use mono; then
+               dodoc README.CSharp
+       fi
+
+       if use examples; then
+               docinto /usr/share/doc/${PF}/samples
+               dodoc samples/{*.m,README,Mmakefile}
+               dodoc -r samples/c_interface \
+                       samples/diff \
+                       samples/muz \
+                       samples/rot13 \
+                       samples/solutions \
+                       samples/solver_types
+
+               if use java; then
+                       dodoc -r samples/java_interface
+               fi
+
+               ecvs_clean "${D}"/usr/share/doc/${PF}/samples
+       fi
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}