www-apps/icingaweb2: 2.7.3 stable amd64/x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 18 Nov 2019 15:23:13 +0000 (09:23 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 18 Nov 2019 15:28:48 +0000 (09:28 -0600)
Package-Manager: Portage-2.3.76, Repoman-2.3.18
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
www-apps/icingaweb2/Manifest
www-apps/icingaweb2/icingaweb2-2.6.3.ebuild [deleted file]
www-apps/icingaweb2/icingaweb2-2.7.3.ebuild

index ad6384a490d5bd33412fd93cd4d411e40bba973e..2de5e7cba50b5ecc3407c3f228e2686a82a39dc9 100644 (file)
@@ -1,3 +1,2 @@
-DIST icingaweb2-2.6.3.tar.gz 8174959 BLAKE2B 6301a0a509031828b8db886e4ab060596f2239de4e65fe714d98a8f8f73305a1116b534f5c2747ab78446ff39b34fa96fe4eae758942aab2de4946c7cf1cdbcb SHA512 f1d14c7ed87cd677a1c4ac03fd6a54514e7e4693000215e0e1628b0480c738848858546e54866eda3a55b4e7c35b5837ad01dc08b5b76502e24d5a727e271710
 DIST icingaweb2-2.7.1.tar.gz 8389123 BLAKE2B f5e469c1fde2b7bc2c22f898a5fb5370ca3788571501f070ed56b32afe8a155aafe70a06bbe09b77cd996725c3e176363aaf0fa885bc843102c56ddfa14da11d SHA512 0300e483e83699a79750dcfd4467a151fcfa95a1eb8735e8d0d8e5d59595ad252b630add3cb462fa4c115b2891f9ab904739ee36d5eb7fcdfb489c9d7658f1b6
 DIST icingaweb2-2.7.3.tar.gz 8388950 BLAKE2B 8d32f770020f72f1fbbf4c73de1935430976afe976c0b4497a1dd470aad286a9ec57d16dcd1f3f7354082206033d58b43966884c453fd8dd4106c13d8d3e8359 SHA512 eee3f81bb3eb29eeaeffe2f890639a12d75f9acf3b7c6649faaff3ab817ab2a5b6cd93b31637794969817f2d42ef5a46704fdc09488642caf6380f57c90d97cb
diff --git a/www-apps/icingaweb2/icingaweb2-2.6.3.ebuild b/www-apps/icingaweb2/icingaweb2-2.6.3.ebuild
deleted file mode 100644 (file)
index 4d66e26..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit depend.apache eutils multilib user
-
-DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
-HOMEPAGE="http://www.icinga.org/"
-
-if [[ ${PV} == *9999 ]];then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
-       EGIT_BRANCH="master"
-else
-       SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
-       KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
-REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
-
-DEPEND=">=net-analyzer/icinga2-2.1.1
-               dev-php/pecl-imagick
-               pdf? ( media-gfx/imagemagick[png] )
-               apache2-server? ( >=www-servers/apache-2.4.0 )
-               nginx? ( >=www-servers/nginx-1.7.0:* )
-               || (
-                       dev-lang/php:5.6[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
-                       dev-lang/php:7.1[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
-                       dev-lang/php:7.2[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
-                       dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
-               )"
-RDEPEND="${DEPEND}"
-
-want_apache2
-
-pkg_setup() {
-       depend.apache_pkg_setup
-
-       enewgroup icingaweb2
-       enewgroup icingacmd
-       use nginx && usermod -a -G icingacmd,icingaweb2 nginx
-       use apache2 && usermod -a -G icingacmd,icingaweb2 apache
-}
-
-pkg_config() {
-       if [[ -d /etc/icingaweb2 ]] ; then
-               einfo "Updating existing installation ..."
-       else
-               einfo "Running first time setup ..."
-               einfo "Creating configuration directory ..."
-               /usr/share/${PN}/bin/icingacli setup config directory
-               einfo "Creating authentication token for web setup ..."
-               /usr/share/${PN}/bin/icingacli setup token create
-               if use apache2 ; then
-                       einfo "The following might be useful for your Apache2 configuration:"
-                       /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
-               fi
-               if use nginx ; then
-                       einfo "The following might be useful for your NGinx configuration:"
-                       /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
-               fi
-       fi
-       einfo "All done."
-}
-
-src_install() {
-       insinto "/usr/share/${PN}"
-       doins -r "${S}"/*
-       fperms -R a+rX "/usr/share/${PN}/public/"
-       fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
-}
-
-pkg_postinst() {
-       einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
-}
index 45655f2ebdb1cd5e027dde6ee1909b7057b77566..4d66e260c407528017b97314c2b9f96f2c1ba82e 100644 (file)
@@ -14,7 +14,7 @@ if [[ ${PV} == *9999 ]];then
        EGIT_BRANCH="master"
 else
        SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
+       KEYWORDS="amd64 x86"
 fi
 
 LICENSE="GPL-2"