dev-ruby/msgpack: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sun, 4 Feb 2018 14:50:06 +0000 (15:50 +0100)
committerHans de Graaff <graaff@gentoo.org>
Sun, 4 Feb 2018 15:14:42 +0000 (16:14 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-ruby/msgpack/Manifest
dev-ruby/msgpack/msgpack-1.1.0-r1.ebuild [deleted file]
dev-ruby/msgpack/msgpack-1.2.0.ebuild [deleted file]

index 350606dffbcc5002ab289c298d51b29ec426b200..9fb3da19dbf0b3bf73d2e80b5fa3af9fc75ea6cc 100644 (file)
@@ -1,3 +1 @@
-DIST msgpack-1.1.0.gem 78336 BLAKE2B 34b450bfded43cbbde3246ec581191de85131b6b74b4bf57ce6dce26cde3d6d40ab9f018e28b4b2e2b144c44cfaafd704ca4edd641371b179b3779f43c6ce23a SHA512 0142c9a446a476a7b4f9212513dd7b1fbe107193a473873f4eb6f4321d5515c42ea3540ac4de17f37f9e833f19bb75594d14b84ccf70b16d2a3840e066c873da
-DIST msgpack-1.2.0.gem 77824 BLAKE2B 15b44b5de8ae02ec6864323241a8827099d912850158c1bb81d32840ff7f0c7e53351d30b209f7c0bfea9e099c34ec724c98420bec45e0701918d883a16a8367 SHA512 c81d68519d5dfc6188799a889fde3d5aec0fc4231366da61914b028e8ef23c8de0bdc2399e634327ca1885566c14ceffe08def795417e386834d07dddf5f8836
 DIST msgpack-1.2.2.gem 78848 BLAKE2B b3ae75ebd6159a78c6a31ecc45bfe0474d5fe91672b6c9dfe96a561b07ebb5bc9ebf91477bc370fba199c5a8c187faa4995a90aa0209b8af81e6d06cd2e58b7b SHA512 7f7fa3350485c3888a42a78fc53f91029208bc6ee483b4c1a082dfa515d435295b6d2f57e9c4cc3f7805349e4a21854585997075d2535c0343af4ae1ec66a802
diff --git a/dev-ruby/msgpack/msgpack-1.1.0-r1.ebuild b/dev-ruby/msgpack/msgpack-1.1.0-r1.ebuild
deleted file mode 100644 (file)
index dd26691..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
-HOMEPAGE="https://msgpack.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~x86-fbsd"
-IUSE="doc"
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
-       sed -i -e '/bundler/I s:^:#:' Rakefile || die
-
-       # Remove jruby-specific specs that are run also for other rubies.
-       rm -rf spec/jruby || die
-
-       sed -i -e '/git ls-files/d' msgpack.gemspec || die
-}
-
-each_ruby_configure() {
-       ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
-
-       # rb_num2int is not inlined on 32 bit arches but also not explicitly
-       # defined, bug 582968
-       sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
-}
-
-each_ruby_compile() {
-       emake V=1 -Cext/${PN}
-       cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
-}
diff --git a/dev-ruby/msgpack/msgpack-1.2.0.ebuild b/dev-ruby/msgpack/msgpack-1.2.0.ebuild
deleted file mode 100644 (file)
index dd26691..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
-HOMEPAGE="https://msgpack.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~x86-fbsd"
-IUSE="doc"
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
-       sed -i -e '/bundler/I s:^:#:' Rakefile || die
-
-       # Remove jruby-specific specs that are run also for other rubies.
-       rm -rf spec/jruby || die
-
-       sed -i -e '/git ls-files/d' msgpack.gemspec || die
-}
-
-each_ruby_configure() {
-       ${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
-
-       # rb_num2int is not inlined on 32 bit arches but also not explicitly
-       # defined, bug 582968
-       sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
-}
-
-each_ruby_compile() {
-       emake V=1 -Cext/${PN}
-       cp ext/${PN}/msgpack$(get_modname) lib/${PN} || die "Unable to install msgpack library."
-}