dev-python/pygit2: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Mon, 1 Jan 2018 22:05:28 +0000 (23:05 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 2 Jan 2018 06:18:47 +0000 (07:18 +0100)
dev-python/pygit2/Manifest
dev-python/pygit2/files/pygit2-0.26.1-internet-tests.patch [deleted file]
dev-python/pygit2/pygit2-0.26.1.ebuild [deleted file]

index 0cb597f3afc5a79f19884f3729a64b39e455eaf3..d612c14e31f4db62b3dd0cfe53a70a5dc33af612 100644 (file)
@@ -1,3 +1,2 @@
 DIST pygit2-0.25.1.tar.gz 456580 BLAKE2B b7a9ce90076f2475df41f2e5ee8cbf7cb2ca68553076ae05cb2e8bdd68067f7373e33dfb03cadf90b7f410b5d5989b902b545fddbb1e3a9f17eb17d50692e982 SHA512 19908c874d5c2469609a54893f37367480d27ff03583c38b474ebb125dc9db95dc60776a120bb05662938d6eb62d4bcef24f684688e97e3453ccc27e015736cd
-DIST pygit2-0.26.1.tar.gz 458526 BLAKE2B 703093a5a292e92c90987785065f3a1590addc09d72311f75b22caf6fe1a17be8fb16cf777189835204cb7dc4d2066e841d3d4327e2cc040c312e22a4c75a8ee SHA512 23585bc0f41458442889b5434347cbc11d6c729898864262426f84e5b9239164bb58c6e910d2381b25f1b8be271674c1a6960630a504c40accdd30e487d27a7d
 DIST pygit2-0.26.3.tar.gz 462080 BLAKE2B b3c4b9b8a6aeba22a70a8d2ef1393dace3a065a3625ee3574058e333bca4ba1d60223939f412eecf5ae9d93a81fb81c4a536af46aa047c2c82a48bd81afe4cf9 SHA512 6f727686221d4e8c348f836b7ad278b48a4b971a121b9953c2cf7163bf093936d838aaf83e9edb8628757624ab27e8345a2fb29eb1a79a30e06c0ab0a77e4cc6
diff --git a/dev-python/pygit2/files/pygit2-0.26.1-internet-tests.patch b/dev-python/pygit2/files/pygit2-0.26.1-internet-tests.patch
deleted file mode 100644 (file)
index 6b96eb4..0000000
+++ /dev/null
@@ -1,133 +0,0 @@
-From 24a929d003f1b6b4899f41cb227293e8c4b62eb7 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 21 Nov 2017 17:53:48 +0100
-Subject: [PATCH] Disable tests requiring network access
-
----
- test/test_credentials.py | 3 +++
- test/test_repository.py  | 1 +
- test/test_submodule.py   | 4 ++++
- 3 files changed, 8 insertions(+)
-
-diff --git a/test/test_credentials.py b/test/test_credentials.py
-index 7921a41..e60383a 100644
---- a/test/test_credentials.py
-+++ b/test/test_credentials.py
-@@ -70,39 +70,42 @@ class CredentialCreateTest(utils.NoRepoTestCase):
-         username = "git"
-  
-         cred = KeypairFromAgent(username)
-         self.assertEqual((username, None, None, None), cred.credential_tuple)
- class CredentialCallback(utils.RepoTestCase):
-+    @unittest.skip('requires Internet access')
-     def test_callback(self):
-         class MyCallbacks(pygit2.RemoteCallbacks):
-             @staticmethod
-             def credentials(url, username, allowed):
-                 self.assertTrue(allowed & GIT_CREDTYPE_USERPASS_PLAINTEXT)
-                 raise Exception("I don't know the password")
-         url = "https://github.com/github/github"
-         remote = self.repo.create_remote("github", url)
-         self.assertRaises(Exception, lambda: remote.fetch(callbacks=MyCallbacks()))
-+    @unittest.skip('requires Internet access')
-     def test_bad_cred_type(self):
-         class MyCallbacks(pygit2.RemoteCallbacks):
-             @staticmethod
-             def credentials(url, username, allowed):
-                 self.assertTrue(allowed & GIT_CREDTYPE_USERPASS_PLAINTEXT)
-                 return Keypair("git", "foo.pub", "foo", "sekkrit")
-         url = "https://github.com/github/github"
-         remote = self.repo.create_remote("github", url)
-         self.assertRaises(TypeError, lambda: remote.fetch(callbacks=MyCallbacks()))
- class CallableCredentialTest(utils.RepoTestCase):
-+    @unittest.skip('requires Internet access')
-     def test_user_pass(self):
-         credentials = UserPass("libgit2", "libgit2")
-         callbacks = pygit2.RemoteCallbacks(credentials=credentials)
-         url = "https://bitbucket.org/libgit2/testgitrepository.git"
-         remote = self.repo.create_remote("bb", url)
-         remote.fetch(callbacks=callbacks)
-diff --git a/test/test_repository.py b/test/test_repository.py
-index 941851b..33f0571 100644
---- a/test/test_repository.py
-+++ b/test/test_repository.py
-@@ -569,14 +569,15 @@ class CloneRepositoryTest(utils.NoRepoTestCase):
-             return repo.remotes.create("custom_remote", url)
-         repo = clone_repository(url, repo_path, repository=create_repository, remote=create_remote)
-         self.assertFalse(repo.is_empty)
-         self.assertTrue('refs/remotes/custom_remote/master' in repo.listall_references())
-         self.assertIsNotNone(repo.remotes["custom_remote"])
-+    @unittest.skip('requires Internet access')
-     def test_clone_with_credentials(self):
-         repo = clone_repository(
-             "https://bitbucket.org/libgit2/testgitrepository.git",
-             self._temp_dir, callbacks=pygit2.RemoteCallbacks(credentials=pygit2.UserPass("libgit2", "libgit2")))
-         self.assertFalse(repo.is_empty)
-diff --git a/test/test_submodule.py b/test/test_submodule.py
-index f123b8b..df44e16 100644
---- a/test/test_submodule.py
-+++ b/test/test_submodule.py
-@@ -49,14 +49,15 @@ class SubmoduleTest(utils.SubmoduleRepoTestCase):
-         self.assertIsNotNone(s)
-     def test_listall_submodules(self):
-         submodules = self.repo.listall_submodules()
-         self.assertEqual(len(submodules), 1)
-         self.assertEqual(submodules[0], SUBM_PATH)
-+    @unittest.skip('requires Internet access')
-     def test_submodule_open(self):
-         s = self.repo.lookup_submodule(SUBM_PATH)
-         self.repo.init_submodules()
-         self.repo.update_submodules()
-         r = s.open()
-         self.assertIsNotNone(r)
-         self.assertEqual(str(r.head.target), SUBM_HEAD_SHA)
-@@ -69,28 +70,31 @@ class SubmoduleTest(utils.SubmoduleRepoTestCase):
-         s = self.repo.lookup_submodule(SUBM_PATH)
-         self.assertEqual(SUBM_PATH, s.path)
-     def test_url(self):
-         s = self.repo.lookup_submodule(SUBM_PATH)
-         self.assertEqual(SUBM_URL, s.url)
-+    @unittest.skip('requires Internet access')
-     def test_init_and_update(self):
-         subrepo_file_path = os.path.join(self.repo_path, 'submodule', 'setup.py')
-         self.assertFalse(os.path.exists(subrepo_file_path))
-         self.repo.init_submodules()
-         self.repo.update_submodules()
-         self.assertTrue(os.path.exists(subrepo_file_path))
-+    @unittest.skip('requires Internet access')
-     def test_specified_update(self):
-         subrepo_file_path = os.path.join(self.repo_path, 'submodule', 'setup.py')
-         self.assertFalse(os.path.exists(subrepo_file_path))
-         self.repo.init_submodules(submodules=['submodule'])
-         self.repo.update_submodules(submodules=['submodule'])
-         self.assertTrue(os.path.exists(subrepo_file_path))
-+    @unittest.skip('requires Internet access')
-     def test_oneshot_update(self):
-         subrepo_file_path = os.path.join(self.repo_path, 'submodule', 'setup.py')
-         self.assertFalse(os.path.exists(subrepo_file_path))
-         self.repo.update_submodules(init=True)
-         self.assertTrue(os.path.exists(subrepo_file_path))
- if __name__ == '__main__':
--- 
-2.15.0
-
diff --git a/dev-python/pygit2/pygit2-0.26.1.ebuild b/dev-python/pygit2/pygit2-0.26.1.ebuild
deleted file mode 100644 (file)
index d121e89..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 eapi7-ver
-
-DESCRIPTION="Python bindings for libgit2"
-HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.python.org/pypi/pygit2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
-       =dev-libs/libgit2-$(ver_cut 1-2)*
-       >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
-       "${FILESDIR}"/pygit2-0.26.1-internet-tests.patch
-)
-
-python_test() {
-       esetup.py test --args='-v'
-}