app-i18n/fbterm: version bump to 1.7_p20190503
authorAlexey Sokolov <sokolov@google.com>
Wed, 22 Apr 2020 09:34:37 +0000 (10:34 +0100)
committerAkinori Hattori <hattya@gentoo.org>
Wed, 20 May 2020 13:45:17 +0000 (22:45 +0900)
An example improvement: a correct TERM value inside the terminal
("fbterm" instead of "linux")

Closes: https://bugs.gentoo.org/714002
Closes: https://github.com/gentoo/gentoo/pull/15467
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Alexey Sokolov <sokolov@google.com>
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-i18n/fbterm/Manifest
app-i18n/fbterm/fbterm-1.7_p20190503.ebuild [new file with mode: 0644]
app-i18n/fbterm/metadata.xml

index 4b231d16f15cdc43e1378ba6ca1518201f10f7a0..da167298d65a33453b999752f03f33eed11b5939 100644 (file)
@@ -1 +1,2 @@
 DIST fbterm-1.7.0.tar.gz 188642 BLAKE2B 2f4e0a989a58d6dd67e7696786d820f15b18039d8912b967de55b09aa03c723cad1d76171a264c41487171f6650089f8a7e02e50bed267f2465fc8a6af62c57e SHA512 ba78b5118b5e4c65046f7f91ce88cb4f828e2debb34358df8518e1907a8d601a2be4dfcf144e84494dc30e4828d333574debe8dd3ffb59e2169c3e48ba1f6a10
+DIST fbterm-1.7_p20190503.tar.gz 187225 BLAKE2B 9efa290c73dae49e12bb53d44c502a58fa5baaf517248b18ae1218285a3785fe276bf028613eac0a78ccee51c8b392153533dffd1e2b88201cccf8badb6d34e1 SHA512 13a57f8c5fff1d9c70021cd01f554a76e5465ae49b05a5aa49949caf31eb2b8fc231bdfba6ac42840542b73edc4ab66e487eebd0fa9d92761c7193294edadf81
diff --git a/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild b/app-i18n/fbterm/fbterm-1.7_p20190503.ebuild
new file mode 100644 (file)
index 0000000..92924b9
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools fcaps
+
+DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
+HOMEPAGE="https://github.com/gjedeer/fbterm"
+
+MY_COMMIT="ccea326dd73f4d6b6442fde7ba7c2be9cd35c6df"
+SRC_URI="https://github.com/gjedeer/fbterm/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/fbterm-${MY_COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gpm video_cards_vesa"
+
+DEPEND="
+       media-libs/fontconfig
+       media-libs/freetype:2
+       >=sys-libs/ncurses-6.1
+       gpm? ( sys-libs/gpm )
+       video_cards_vesa? ( dev-libs/libx86 )
+"
+BDEPEND="
+       virtual/pkgconfig
+"
+
+FILECAPS=(
+       cap_sys_tty_config+ep usr/bin/${PN}
+)
+
+src_prepare() {
+       # bug #648472
+       sed -i "s/terminfo//" Makefile.am || die "Can't remove terminfo"
+
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable gpm) \
+               $(use_enable video_cards_vesa vesa)
+}
+
+src_install() {
+       default
+
+       use filecaps || fperms u+s /usr/bin/${PN}
+}
+
+pkg_postinst() {
+       fcaps_pkg_postinst
+
+       elog "${PN} won't work with vga16fb. You have to use other native"
+       elog "framebuffer drivers or vesa driver."
+       elog "See ${EPREFIX}/usr/share/doc/${P}/README for details."
+       elog
+       elog "To use ${PN}, ensure you are in video group."
+}
index 165c6df0ed299c1c74364634c7ea3938662c29d4..ca241aea3494db4047ba56e9a9b90067c8cd112f 100644 (file)
@@ -6,6 +6,6 @@
     <name>Cjk</name>
   </maintainer>
   <upstream>
-    <remote-id type="google-code">fbterm</remote-id>
+    <remote-id type="github">gjedeer/fbterm</remote-id>
   </upstream>
 </pkgmetadata>