dev-haskell/test-framework-hunit: bump up to 0.3.0.2-r1
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 12:51:45 +0000 (12:51 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 12:51:45 +0000 (12:51 +0000)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/test-framework-hunit/test-framework-hunit-0.3.0.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-haskell/test-framework-hunit/test-framework-hunit-0.3.0.2-r1.ebuild b/dev-haskell/test-framework-hunit/test-framework-hunit-0.3.0.2-r1.ebuild
new file mode 100644 (file)
index 0000000..c64075c
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: +base4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="HUnit support for the test-framework package"
+HOMEPAGE="https://batterseapower.github.io/test-framework/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/extensible-exceptions-0.1.1:=[profile?] <dev-haskell/extensible-exceptions-0.2.0:=[profile?]
+       >=dev-haskell/hunit-1.2:=[profile?]
+       >=dev-haskell/test-framework-0.2.0:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+       cabal_chdeps \
+               'HUnit >= 1.2 && < 1.4' 'HUnit >= 1.2'
+       default
+}
+
+src_configure() {
+       haskell-cabal_src_configure \
+               --flag=base4
+}