dev-java/netbeans-harness: version bump
authorMiroslav Šulc <fordfrog@gentoo.org>
Fri, 6 Jan 2012 10:47:01 +0000 (10:47 +0000)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 6 Jan 2012 10:47:01 +0000 (10:47 +0000)
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64

dev-java/netbeans-harness/ChangeLog
dev-java/netbeans-harness/netbeans-harness-7.1.ebuild [new file with mode: 0644]

index 7930ffd3bc31ddec33db54d5fca25d6c751091e5..6ea62ae8e3520feb1008ebfedc70b44bc4bd4447 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-java/netbeans-harness
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-harness/ChangeLog,v 1.7 2011/10/24 23:59:49 fordfrog Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-harness/ChangeLog,v 1.8 2012/01/06 10:47:01 fordfrog Exp $
+
+*netbeans-harness-7.1 (06 Jan 2012)
+
+  06 Jan 2012; Miroslav Šulc <fordfrog@gentoo.org>
+  +netbeans-harness-7.1.ebuild:
+  Version bump
 
   24 Oct 2011; Miroslav Šulc <fordfrog@gentoo.org>
   netbeans-harness-7.0.1.ebuild:
diff --git a/dev-java/netbeans-harness/netbeans-harness-7.1.ebuild b/dev-java/netbeans-harness/netbeans-harness-7.1.ebuild
new file mode 100644 (file)
index 0000000..590f27b
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-harness/netbeans-harness-7.1.ebuild,v 1.1 2012/01/06 10:47:01 fordfrog Exp $
+
+EAPI="4"
+WANT_ANT_TASKS="ant-nodeps"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Netbeans Harness"
+HOMEPAGE="http://netbeans.org/features/platform/"
+SLOT="7.1"
+SOURCE_URL="http://dlc.sun.com.edgesuite.net/netbeans/7.1/final/zip/netbeans-7.1-201112071828-src.zip"
+SRC_URI="${SOURCE_URL}
+       http://dev.gentoo.org/~fordfrog/distfiles/netbeans-9999-r1-build.xml.patch.bz2
+       http://hg.netbeans.org/binaries/A806D99716C5E9441BFD8B401176FDDEFC673022-bindex-2.2.jar
+       http://hg.netbeans.org/binaries/418FC62C8A6EF5311987B01FE389B1F88EFDDCA2-jemmy-2.3.0.0.jar"
+LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}"
+
+CDEPEND="~dev-java/netbeans-platform-${PV}
+       dev-java/javahelp:0"
+DEPEND="virtual/jdk:1.6
+       app-arch/unzip
+       ${CDEPEND}
+       >=dev-java/junit-4.4:4"
+RDEPEND=">=virtual/jdk-1.6
+       ${CDEPEND}"
+
+INSTALL_DIR="/usr/share/${PN}-${SLOT}"
+
+EANT_BUILD_XML="nbbuild/build.xml"
+EANT_BUILD_TARGET="rebuild-cluster"
+EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.harness -Dext.binaries.downloaded=true"
+EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
+JAVA_PKG_BSFIX="off"
+
+src_unpack() {
+       unpack $(basename ${SOURCE_URL})
+
+       einfo "Deleting bundled jars..."
+       find -name "*.jar" -type f -delete
+
+       unpack netbeans-9999-r1-build.xml.patch.bz2
+
+       pushd "${S}" >/dev/null || die
+       ln -s "${DISTDIR}"/A806D99716C5E9441BFD8B401176FDDEFC673022-bindex-2.2.jar apisupport.harness/external/bindex-2.2.jar || die
+       ln -s "${DISTDIR}"/418FC62C8A6EF5311987B01FE389B1F88EFDDCA2-jemmy-2.3.0.0.jar jemmy/external/jemmy-2.3.0.0.jar || die
+       popd >/dev/null || die
+}
+
+src_prepare() {
+       einfo "Deleting bundled class files..."
+       find -name "*.class" -type f | xargs rm -vf
+
+       epatch netbeans-9999-r1-build.xml.patch
+
+       # Support for custom patches
+       if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
+               local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
+
+               if [ -n "${files}" ] ; then
+                       einfo "Applying custom patches:"
+
+                       for file in ${files} ; do
+                               epatch "${file}"
+                       done
+               fi
+       fi
+
+       einfo "Symlinking external libraries..."
+       java-pkg_jar-from --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
+       java-pkg_jar-from --into apisupport.harness/external javahelp jsearch.jar jsearch-2.0_05.jar
+       java-pkg_jar-from --build-only --into libs.junit4/external junit-4 junit.jar junit-4.10.jar
+
+       einfo "Linking in other clusters..."
+       mkdir "${S}"/nbbuild/netbeans || die
+       pushd "${S}"/nbbuild/netbeans >/dev/null || die
+
+       ln -s /usr/share/netbeans-platform-${SLOT} platform || die
+       cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+       touch nb.cluster.platform.built
+
+       popd >/dev/null || die
+
+       java-pkg-2_src_prepare
+}
+
+src_install() {
+       pushd nbbuild/netbeans/harness >/dev/null || die
+
+       insinto ${INSTALL_DIR}
+
+       grep -E "/harness$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
+
+       doins -r *
+       fperms 755 launchers/app.sh
+       find "${D}" -name "*.exe" -type f -delete
+
+       popd >/dev/null || die
+
+       local instdir=${INSTALL_DIR}/antlib
+       pushd "${D}"/${instdir} >/dev/null || die
+       # bindex-2.2.jar
+       rm jsearch-2.0_05.jar && dosym /usr/share/javahelp/lib/jsearch.jar ${instdir}/jsearch-2.0_05.jar || die
+       popd >/dev/null || die
+
+       local instdir=${INSTALL_DIR}/modules/ext
+       pushd "${D}"/${instdir} >/dev/null || die
+       # jemmy-2.3.0.0.jar
+       popd >/dev/null || die
+
+       dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/harness
+}