x11-libs/libXfont2: Port to EAPI 7
authorMatt Turner <mattst88@gentoo.org>
Sat, 14 Sep 2019 19:11:09 +0000 (12:11 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 14 Sep 2019 19:15:09 +0000 (12:15 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/libXfont2/libXfont2-9999.ebuild

index 9463d5e13105e5d5fdea3f0c6cbe38084c009d28..cfd74911baa4e1a57948d895e3893006e1f21126 100644 (file)
@@ -1,11 +1,11 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
 XORG_PACKAGE_NAME=libxfont
 XORG_DOC=doc
-inherit xorg-2
+inherit xorg-3
 
 DESCRIPTION="X.Org Xfont library"
 
@@ -15,12 +15,13 @@ IUSE="bzip2 ipv6 truetype"
 RDEPEND="sys-libs/zlib
        x11-base/xorg-proto
        x11-libs/libfontenc
-       x11-libs/xtrans
        bzip2? ( app-arch/bzip2 )
        truetype? ( >=media-libs/freetype-2 )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+       x11-base/xorg-proto
+       x11-libs/xtrans"
 
-src_configure() {
+pkg_setup() {
        XORG_CONFIGURE_OPTIONS=(
                $(use_enable ipv6)
                $(use_enable doc devel-docs)
@@ -29,5 +30,4 @@ src_configure() {
                $(use_enable truetype freetype)
                --without-fop
        )
-       xorg-2_src_configure
 }