media-libs/fontconfig: use host uuid on Darwin
authorFabian Groffen <grobian@gentoo.org>
Sat, 2 Jun 2018 14:14:02 +0000 (16:14 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sat, 2 Jun 2018 14:14:31 +0000 (16:14 +0200)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

media-libs/fontconfig/fontconfig-2.13.0-r4.ebuild

index fb9e57feeeb9580f1fc9c395c2ace6dff8cd7176..c80ddcea1c0ea6007e48a3b8c642f6c871967d60 100644 (file)
@@ -12,14 +12,14 @@ SRC_URI="https://fontconfig.org/release/${P}.tar.bz2"
 LICENSE="MIT"
 SLOT="1.0"
 [[ $(ver_cut 3) -ge 90 ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="doc static-libs"
 
 # Purposefully dropped the xml USE flag and libxml2 support.  Expat is the
 # default and used by every distro.  See bug #283191.
 RDEPEND=">=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
        >=media-libs/freetype-2.9[${MULTILIB_USEDEP}]
-       sys-apps/util-linux[${MULTILIB_USEDEP}]
+       !elibc_Darwin? ( sys-apps/util-linux[${MULTILIB_USEDEP}] )
        virtual/libintl[${MULTILIB_USEDEP}]"
 DEPEND="${RDEPEND}
        virtual/pkgconfig
@@ -73,6 +73,13 @@ multilib_src_configure() {
                ;;
        esac
 
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               # Darwin provides uuid in libSystem, avoid pkg-config check for
+               # it with some dummy values
+               export UUID_CFLAGS="-I/usr/include/uuid-dummy"
+               export UUID_LIBS="-lc"
+       fi
+
        local myeconfargs=(
                $(use_enable doc docbook)
                $(use_enable static-libs static)