dev-util/lxqt-build-tools: new package.
authorRichard Nespithal <richard@nespithal.com>
Wed, 23 Nov 2016 15:40:08 +0000 (16:40 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 12 Mar 2017 19:04:28 +0000 (20:04 +0100)
lxqt-build-tools is summarizing several tools which are needed to build
LXQt as well as some of the other components maintained by the project.

Closes: https://github.com/gentoo/gentoo/pull/3521

dev-util/lxqt-build-tools/Manifest [new file with mode: 0644]
dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild [new file with mode: 0644]
dev-util/lxqt-build-tools/metadata.xml [new file with mode: 0644]

diff --git a/dev-util/lxqt-build-tools/Manifest b/dev-util/lxqt-build-tools/Manifest
new file mode 100644 (file)
index 0000000..c0a62e8
--- /dev/null
@@ -0,0 +1 @@
+DIST lxqt-build-tools-0.2.0.tar.xz 15552 SHA256 4b2b6788260e167358f3bb295cc2faa820cb52670d3213a6317419db893037d2 SHA512 40349710a20d3f06761c57b5d40aa05cb194fa4b50d1e41e4bd7e6adf1beb5c7209f3d4965869a301369df17ec1d75f55aede7ab0fe88a55d692cd56d72121de WHIRLPOOL 9725e8181a7f6e6e05c172336b5b489caf9573e7d6beb472ffd9a6ae8769f961b285f43d3ef05103e0374c50abf55afc81d028e487668d1b0cbe8fcc2787a878
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.2.0.ebuild
new file mode 100644 (file)
index 0000000..0e20e21
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="LXQt Build tools"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+       SRC_URI="http://downloads.lxqt.org/${PN}/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="dev-qt/qtcore:5"
+
+src_configure() {
+       cmake-utils_src_configure
+}
diff --git a/dev-util/lxqt-build-tools/metadata.xml b/dev-util/lxqt-build-tools/metadata.xml
new file mode 100644 (file)
index 0000000..a40a83a
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+    <email>lxqt@gentoo.org</email>
+    <name>LXQt</name>
+  </maintainer>
+</pkgmetadata>