sys-block/rts_pstor: Fix build with kernel 4.2.0
authorVikraman Choudhury <vikraman@gentoo.org>
Thu, 17 Sep 2015 05:31:17 +0000 (01:31 -0400)
committerVikraman Choudhury <vikraman@gentoo.org>
Thu, 17 Sep 2015 05:31:17 +0000 (01:31 -0400)
Gentoo-Bug: 559668

Package-Manager: portage-2.2.20.1

sys-block/rts_pstor/files/rts_pstor-vmalloc.patch [new file with mode: 0644]
sys-block/rts_pstor/rts_pstor-1.10-r5.ebuild [moved from sys-block/rts_pstor/rts_pstor-1.10-r4.ebuild with 96% similarity]

diff --git a/sys-block/rts_pstor/files/rts_pstor-vmalloc.patch b/sys-block/rts_pstor/files/rts_pstor-vmalloc.patch
new file mode 100644 (file)
index 0000000..3b3f4be
--- /dev/null
@@ -0,0 +1,44 @@
+diff -Naur rts_pstor.a/ms.c rts_pstor.b/ms.c
+--- rts_pstor.a/ms.c   2011-01-11 04:11:07.000000000 -0500
++++ rts_pstor.b/ms.c   2015-09-17 01:28:41.816067799 -0400
+@@ -23,6 +23,7 @@
+ #include <linux/blkdev.h>
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
++#include <linux/vmalloc.h>
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
+diff -Naur rts_pstor.a/rtsx_chip.c rts_pstor.b/rtsx_chip.c
+--- rts_pstor.a/rtsx_chip.c    2011-01-11 04:11:07.000000000 -0500
++++ rts_pstor.b/rtsx_chip.c    2015-09-17 01:28:13.680536901 -0400
+@@ -24,6 +24,7 @@
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
+ #include <linux/workqueue.h>
++#include <linux/vmalloc.h>
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
+diff -Naur rts_pstor.a/rtsx_scsi.c rts_pstor.b/rtsx_scsi.c
+--- rts_pstor.a/rtsx_scsi.c    2011-01-11 04:11:07.000000000 -0500
++++ rts_pstor.b/rtsx_scsi.c    2015-09-17 01:28:42.688053259 -0400
+@@ -23,6 +23,7 @@
+ #include <linux/blkdev.h>
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
++#include <linux/vmalloc.h>
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
+diff -Naur rts_pstor.a/xd.c rts_pstor.b/xd.c
+--- rts_pstor.a/xd.c   2011-01-11 04:11:07.000000000 -0500
++++ rts_pstor.b/xd.c   2015-09-17 01:28:42.689053242 -0400
+@@ -23,6 +23,7 @@
+ #include <linux/blkdev.h>
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
++#include <linux/vmalloc.h>
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
similarity index 96%
rename from sys-block/rts_pstor/rts_pstor-1.10-r4.ebuild
rename to sys-block/rts_pstor/rts_pstor-1.10-r5.ebuild
index c24eb5850d42dc533321500afdaa4a2ee70cacea..91bcd74cdde695f176d89c08e41143e5f2390162 100644 (file)
@@ -30,6 +30,7 @@ src_prepare() {
                && epatch "${FILESDIR}/${PN}-linux-3.8.patch"
        ([ ${KV_MAJOR} -gt 3 ] || ([ ${KV_MAJOR} -eq 3 ] && [ ${KV_MINOR} -ge 10 ])) \
                && epatch "${FILESDIR}/${PN}-linux-3.10.patch"
+       epatch "${FILESDIR}/${PN}-vmalloc.patch"
 }
 
 pkg_setup() {