dev-vcs/tortoisehg: Bump to version 4.7
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 23 Aug 2018 22:51:10 +0000 (00:51 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 23 Aug 2018 22:51:10 +0000 (00:51 +0200)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-vcs/tortoisehg/Manifest
dev-vcs/tortoisehg/tortoisehg-4.7.ebuild [new file with mode: 0644]

index 83b453ab5760eb5d022e9f0e7f5a195b131676cc..f431bb75363bdf8e90e15450b46644cf2cba4b12 100644 (file)
@@ -2,3 +2,4 @@ DIST tortoisehg-4.5.2.tar.gz 7935559 BLAKE2B c69107f28767936232937ee0b730b9b937d
 DIST tortoisehg-4.5.3.tar.gz 7929645 BLAKE2B 95b867f372d636ed84eda918a707e24f4b11e34679ae9ed1c25f82a7aa6bb77f424bd68a99b5f961d14960a2f33005536996de2f3df9871684bb53f68130b1b2 SHA512 0c6c512f7a46a084904a5e66912deb8ef4abb99a6a97c46b6b058537332f091395f4b9b8a4b645d7c42637abbb4e8abe16f5040fd694bb43ea8b4c6ddb1e18f6
 DIST tortoisehg-4.6.1.tar.gz 7947844 BLAKE2B 68d0e8672febb9bfdca763e77cbaff8de79c2de79b61e0096c3ef7370cf9d9287a5fd65fbe3c262e13f185bcf5e384ece5d8365979bc05188e74ccfb49f43543 SHA512 adf5ebfc7a76843b62f66feddfde42c0f915c970a951e037f082ee4a6b393822b023f116dc650d5242838d006dc572235a4089c3805929727435588c24ded480
 DIST tortoisehg-4.6.tar.gz 7947478 BLAKE2B b2176e3fd508a84c247802490822d47ed117f3102b4ddc10987114018611a710696e2910f3e4b63f80357611fd2ebd8333322df1e5f549a9a618ea1b9017e430 SHA512 a57d3f10dde22da48b03252e41286dd40b7e261ae9ac9a0c09c8ccc361773d9f66ddb0f71c7eb800bfdae65587915a988367472885eb473ee810a07828044ce0
+DIST tortoisehg-4.7.tar.gz 7947751 BLAKE2B 8e50ec04e754aae65bf8fd9754ad78070d3fcabadb2af447f9af2c8ca954cf17c635ab4370aa501be24c1c6714c75bf1b5f0f8031f620ca3d4e3dc6098ccea10 SHA512 3c842741275dc08a7f9261fd9989575cb3036d23bb4e1c454ce98ffc721e913286d8f15d10490d108f18df1981295c42e4ada663660844de3ec6976cf77378a3
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.7.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.7.ebuild
new file mode 100644 (file)
index 0000000..7d15282
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+if [[ ${PV} != *9999* ]]; then
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+       HG_DEPEND=">=dev-vcs/mercurial-4.6 <dev-vcs/mercurial-4.8"
+else
+       inherit mercurial
+       EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+       EHG_REVISION="stable"
+       HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+       dev-python/iniparse[${PYTHON_USEDEP}]
+       dev-python/pygments[${PYTHON_USEDEP}]
+       dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+       >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       doc? ( >=dev-python/sphinx-1.0.3 )"
+
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+       if [[ ${L10N+set} ]]; then
+               cd i18n/tortoisehg || die
+               local x y keep
+               for x in *.po; do
+                       keep=false
+                       for y in ${L10N}; do
+                               if [[ ${y} == ${x%.po}* ]]; then
+                                       keep=true
+                                       break
+                               fi
+                       done
+                       ${keep} || rm "${x}" || die
+               done
+               cd "${S}" || die
+       fi
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C doc html
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+       if use doc ; then
+               dohtml -r doc/build/html/
+       fi
+       newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+       domenu contrib/thg.desktop
+
+       # Remove file that collides with >=mercurial-4.0 (bug #599266).
+       rm "${ED%/}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py \
+               || die
+}
+
+pkg_postinst() {
+       elog "When startup of ${PN} fails with an API version mismatch error"
+       elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+       elog "dev-python/qscintilla-python."
+}