dev-python/embedly: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:20 +0000 (17:12 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:20 +0000 (17:12 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/embedly/embedly-0.5.0-r1.ebuild

index 313b05cf3fe11feab7479e7779efec58aecdd813..3721058887b883c39effa15e8eba0cb370c6c247 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+PYTHON_COMPAT=( python3_{5,6} )
 
 inherit distutils-r1
 
@@ -16,17 +16,14 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="test"
+# Testsuite relies upon connection to various sites on the net
+RESTRICT="test"
 
 RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2) )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 
 S="${WORKDIR}/${MY_P}"
 
-# Testsuite relies upon connection to various sites on the net
-RESTRICT="test"
-
 python_test() {
        esetup.py test
 }