games-simulation/micropolis: fix eclass usage, don't call gcc directly
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Tue, 19 Nov 2019 09:47:53 +0000 (10:47 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Tue, 19 Nov 2019 23:27:38 +0000 (23:27 +0000)
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13703
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-simulation/micropolis/micropolis-1.0-r2.ebuild

index 185b1d35b1f0a4eeae0e7230ce743ddd17374204..c329f78b081765aad4b8a12a48088e52af0c6084 100644 (file)
@@ -2,7 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-inherit eutils
+
+inherit desktop eutils toolchain-funcs
 
 DESCRIPTION="Free version of the well-known city building simulation"
 HOMEPAGE="http://www.donhopkins.com/home/micropolis/"
@@ -43,7 +44,7 @@ src_prepare() {
 }
 
 src_compile() {
-       emake -C src LDFLAGS="${LDFLAGS}"
+       emake -C src LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
 }
 
 src_install() {