dev-libs/openssl-compat: limit parallel jobs
authorThomas Deutschmann <whissi@gentoo.org>
Sun, 15 Sep 2019 20:27:47 +0000 (22:27 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 15 Sep 2019 20:28:02 +0000 (22:28 +0200)
Bug: https://bugs.gentoo.org/694512
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-libs/openssl-compat/openssl-compat-1.0.2t.ebuild

index 717d2d311a8eee10b115fc7d938d4e0baf1fef77..292f5d8fd0f9b78d0dd27f21cd009df1171f8b98 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI="7"
 
-inherit flag-o-matic toolchain-funcs multilib multilib-minimal
+inherit flag-o-matic toolchain-funcs multiprocessing multilib multilib-minimal
 
 # openssl-1.0.2-patches-1.6 contain additional CVE patches
 # which got fixed with this release.
@@ -135,6 +135,13 @@ src_prepare() {
        sed -i '/stty -icanon min 0 time 50; read waste/d' config || die
        ./config --test-sanity || die "I AM NOT SANE"
 
+       local make_jobs=$(makeopts_jobs)
+       if [[ ${make_jobs} -gt 6 ]] ; then
+               # bug 694512
+               einfo "Limiting parallel jobs to 6 ..."
+               export MAKEOPTS=-j6
+       fi
+
        multilib_copy_sources
 }