dev-python/ptpython: bump to version 2.0.6.
authorGabriel Linder <linder.gabriel@gmail.com>
Sun, 8 Dec 2019 12:43:59 +0000 (13:43 +0100)
committerAaron Bauman <bman@gentoo.org>
Thu, 12 Dec 2019 19:31:32 +0000 (14:31 -0500)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Gabriel Linder <linder.gabriel@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13917
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-python/ptpython/Manifest
dev-python/ptpython/metadata.xml
dev-python/ptpython/ptpython-2.0.6.ebuild [new file with mode: 0644]

index 8bd053531b2dcec8354488d6ea1649c5f095b8f1..eb75f5f741e68c88de31221c9b63be0405fb96e2 100644 (file)
@@ -1 +1,2 @@
 DIST ptpython-0.33.tar.gz 43295 BLAKE2B 96df547c3a231124e2e34e5dd6d6a2fe661883d8c8f88a25d955c46b250b86319e343adc0a2265841ca69f115e9b0787a431c49db9de2de362cd5d0c4334ae1f SHA512 fce9379e4522b2b644e6159c73e3eff2d0ced8de65462d4ad622f91feb46fa80a9e01a2c7aef1832b4fcf69de5c0c7d229c731149af7029eec46f88a0506ad71
+DIST ptpython-2.0.6.tar.gz 46980 BLAKE2B b78013d898bb01106315a7aea88f40c0a8ba70571ae8fb5376dcf7d67636f4e3d4d329c5c58dc4c2cdca80ec92313938250224c2560f91eda40bff6c5f59736c SHA512 2d0a84e6515ad2e6523774b1136fdc822aed95e27e6a2d857952b703ea5def86de44166c2cffd8d2151cdf246088959d0a41279cb66b1249a865bff3ad02f4cc
index f08e580eb2515757ed38b945471efcb7d4e5fe98..ec02a39c6996ee6469de31516aba9e951f4a3e8e 100644 (file)
@@ -7,6 +7,6 @@
   </maintainer>
   <upstream>
     <remote-id type="pypi">ptpython</remote-id>
-    <remote-id type="github">jonathanslenders/ptpython</remote-id>
+    <remote-id type="github">prompt-toolkit/ptpython</remote-id>
   </upstream>
 </pkgmetadata>
diff --git a/dev-python/ptpython/ptpython-2.0.6.ebuild b/dev-python/ptpython/ptpython-2.0.6.ebuild
new file mode 100644 (file)
index 0000000..0b3ce70
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python REPL build on top of prompt_toolkit"
+HOMEPAGE="https://pypi.org/project/ptpython/ https://github.com/prompt-toolkit/ptpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-python/docopt[${PYTHON_USEDEP}]
+       >=dev-python/jedi-0.9.0[${PYTHON_USEDEP}]
+       >=dev-python/prompt_toolkit-2.0.8[${PYTHON_USEDEP}]
+       <dev-python/prompt_toolkit-2.1.0[${PYTHON_USEDEP}]
+       dev-python/pygments[${PYTHON_USEDEP}]
+"