sys-devel/binutils: tweak 2.32 for gcc-10
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 9 Mar 2020 20:07:11 +0000 (20:07 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 9 Mar 2020 20:07:44 +0000 (20:07 +0000)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/binutils/binutils-2.32-r2.ebuild
sys-devel/binutils/files/binutils-2.32-gcc-10.patch [new file with mode: 0644]

index 3e54336e168a48170ee8e550e303e7d8e379e45d..0242f7095690b146446b021cf1f852204c5572ba 100644 (file)
@@ -55,8 +55,13 @@ PATCH_DEV=${PATCH_DEV:-slyfox}
 [[ -z ${PATCH_VER} ]] || SRC_URI="${SRC_URI}
        https://dev.gentoo.org/~${PATCH_DEV}/distfiles/binutils-${PATCH_BINUTILS_VER}-patches-${PATCH_VER}.tar.xz"
 
-# Disable gold testsuite since it always fails.
-PATCHES=( "${FILESDIR}/${PN}-2.29.1-nogoldtest.patch" )
+PATCHES=(
+       # Disable gold testsuite since it always fails.
+       "${FILESDIR}/${PN}-2.29.1-nogoldtest.patch"
+
+       "${FILESDIR}"/${PN}-2.32-gcc-10.patch
+       "${FILESDIR}"/${PN}-2.33-gcc-10.patch
+)
 
 #
 # The cross-compile logic
diff --git a/sys-devel/binutils/files/binutils-2.32-gcc-10.patch b/sys-devel/binutils/files/binutils-2.32-gcc-10.patch
new file mode 100644 (file)
index 0000000..fa70694
--- /dev/null
@@ -0,0 +1,16 @@
+commit a3972330f49f81b3bea64af0970d22f42ae56ec3
+Author: Martin Liska <mliska@suse.cz>
+Date:   Fri Jun 7 07:36:52 2019 +0200
+
+    Fix a missing include of <string>
+    
+--- a/gold/errors.h
++++ b/gold/errors.h
+@@ -24,6 +24,7 @@
+ #define GOLD_ERRORS_H
+ #include <cstdarg>
++#include <string>
+ #include "gold-threads.h"