dev-python/booleanOperations: Bump to 0.8.2
authorPacho Ramos <pacho@gentoo.org>
Sat, 14 Sep 2019 20:38:34 +0000 (22:38 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 14 Sep 2019 20:38:34 +0000 (22:38 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/booleanOperations/Manifest
dev-python/booleanOperations/booleanOperations-0.8.2.ebuild [new file with mode: 0644]

index efff79f564f0d46a613b5445b8778ec91d34492f..c9d9ef6a9d7eda13fb4a45c91373eada71b31c2b 100644 (file)
@@ -1 +1,2 @@
 DIST booleanOperations-0.8.0.tar.gz 19914 BLAKE2B 121eb4c8587cd56717c757589cadd08334c7a3d90d878c17d24e36b232a1cbf0386a4c1090638818f0e264296796d89a8231204656d2a7432802b385e8200c80 SHA512 76eaeb6a5039f4f5ff3a066545a70c35a512b7ec20e54873cde90a14a18f6a9fc33a2ac356325f7390f206ad2f34412e178212e30065ede41d4b3fa8397eecea
+DIST booleanOperations-0.8.2.tar.gz 165059 BLAKE2B 978b992e84181e8ec437e236e6502a6c135ea011395f3b082881e6b9f5c849632077737064d1102164cf083edc8a7e47c6f4f43d858948d9046ed231c5ac8911 SHA512 3c369ce53bc7b1b53f4441ba79959d4853c9ab767fef17fc41f44812427dcb5ad905fcfac4cee0d616447cccd059fce6a1d168b0766054659fb29b33867d1fb9
diff --git a/dev-python/booleanOperations/booleanOperations-0.8.2.ebuild b/dev-python/booleanOperations/booleanOperations-0.8.2.ebuild
new file mode 100644 (file)
index 0000000..3f2387f
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Boolean operations on paths"
+HOMEPAGE="https://github.com/typemytype/booleanOperations"
+SRC_URI="https://github.com/typemytype/booleanOperations/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+BDEPEND=""
+RDEPEND="${DEPEND}
+       >=dev-python/fonttools-3.32.0[${PYTHON_USEDEP}]
+       dev-python/pyclipper[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+       export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       esetup.py test
+}