app-portage/gemato: Bump to 14.4
authorMichał Górny <mgorny@gentoo.org>
Sun, 17 May 2020 06:29:30 +0000 (08:29 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 17 May 2020 06:29:30 +0000 (08:29 +0200)
Closes: https://bugs.gentoo.org/718066
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/gemato/Manifest
app-portage/gemato/gemato-14.4.ebuild [new file with mode: 0644]

index 2903b73d3e6961e2829398da50230037b33c5ddd..82556c3a915032110afbca26e21f2acca2d2f53e 100644 (file)
@@ -1 +1,2 @@
 DIST gemato-14.3.tar.gz 71325 BLAKE2B d42a5182c12bcc0281df47ddb6b933bb332b9b842b2a5c874c3fa4030ab5a8a16759ee289609d428a3fc1338078cd73d234060354513be88c184d5a6bbec545d SHA512 99904b1a38b8a05ff7bf7c265aa463a56ea3aa6c77dd844dc2d154faae5460e3535f4e9799e8863fda256ee6cd374e051ed98193c9b1fc52dc30c9c2655010cd
+DIST gemato-14.4.tar.gz 72630 BLAKE2B c8956b979d7c8629e245ba339e8ee707cd51ffe545a85c712c31b97ee2aaabef7a4964cac46c9cd8c4954c33529623293a94a26ae40b578a6b640aab15d47835 SHA512 0b514e4ff7773eefd2d9adc063a4fbc6a1e7d9ea3dfa783b1d5a8e6ec1e482533a8c70cd5e200a8b9671161d77e14254ad14aee6659e3c96eb9be3bbedcf11af
diff --git a/app-portage/gemato/gemato-14.4.ebuild b/app-portage/gemato/gemato-14.4.ebuild
new file mode 100644 (file)
index 0000000..37b5909
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{3_6,3_7,3_8} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg tools"
+
+RDEPEND="
+       gpg? ( app-crypt/gnupg )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       if use tools; then
+               exeinto /usr/share/gemato
+               doexe utils/*.{bash,py}
+       fi
+}