app-admin/keepass: remove 2.35-r1
authorMichael Palimaka <kensington@gentoo.org>
Sun, 23 Jul 2017 02:05:25 +0000 (12:05 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Sun, 23 Jul 2017 02:08:01 +0000 (12:08 +1000)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

app-admin/keepass/Manifest
app-admin/keepass/files/keepass-2.20-xsl-path-detection.patch [deleted file]
app-admin/keepass/files/keepass-2.35-new-monoprep-script.sh [deleted file]
app-admin/keepass/keepass-2.35-r1.ebuild [deleted file]

index a40911b337b0f2e7519754226b4ca84d38dda6ae..f9b9d9129ebb0f7973a932e02addfaf045aa5e71 100644 (file)
@@ -1,2 +1 @@
-DIST KeePass-2.35-Source.zip 4840873 SHA256 5faad9381af2f9d808d65ee3d880ff3bca9352c7ce886fea95d54f9169e863df SHA512 9f9bb0875c3261e004f655356e8302858afebb7d41a4e4619affaa5e8e5375ffe4fc2b251db10d1d18ef94e07d60dd9bd8812ecedcd5de4c4fbe641c6a37dede WHIRLPOOL db1d270ac5402021add60739ca4916d9dd81999c53b095d143a34a2886f47c354170e41fee63027be83866c541022c79c3c21111a501cd51bafb972e5fe277e2
 DIST KeePass-2.36-Source.zip 5063221 SHA256 de7e3e9d9bedab13e4d66b0ee941b2ebedaa08d8090f7cd78bd0fc019187d8c8 SHA512 16d51ed6bc437172765f69d1d67862afe7219a0898d13b4609198bbd7b5107620f1be418f5ea6ba23a5e3c7ca12d45ba3f0f3778c516eea6b2b953bc291cfe41 WHIRLPOOL 1d9fbf662757e09c4854010da9f6960fe4bf794eb694b37a9f63d813c1e1d1471257a66f01eac761fed5b06831f659cb81f11eba8858ee4e128cd578a19fcae8
diff --git a/app-admin/keepass/files/keepass-2.20-xsl-path-detection.patch b/app-admin/keepass/files/keepass-2.20-xsl-path-detection.patch
deleted file mode 100644 (file)
index d3805fe..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-KeePass looks for some resources (XSL files) in the executable directory,
-however under UNIX system this not a good idea, so we look into the
-CommonApplicationData SpecialFolder, which usually maps to "/usr/share/".
-So the final search path should be "/usr/share/KeePass/XSL/".
-
-diff --git a/KeePass/Forms/AboutForm.cs b/KeePass/Forms/AboutForm.cs
-index 8a04c87..6083c00 100644
---- a/KeePass/Forms/AboutForm.cs
-+++ b/KeePass/Forms/AboutForm.cs
-@@ -31,9 +31,11 @@ using KeePass.UI;
- using KeePass.Resources;\r
- using KeePass.Util;\r
- using KeePass.DataExchange;\r
-+using KeePass.Native;\r
\r
- using KeePassLib;\r
- using KeePassLib.Utility;\r
-+using KeePassLib.Native;\r
\r
- namespace KeePass.Forms\r
- {\r
-@@ -92,8 +94,21 @@ namespace KeePass.Forms
-                       m_lvComponents.Items.Add(lvi);\r
\r
-                       lvi = new ListViewItem(KPRes.XslStylesheetsKdbx);\r
--                      string strPath = WinUtil.GetExecutable();\r
--                      strPath = UrlUtil.GetFileDirectory(strPath, true, false);\r
-+\r
-+                      string strPath;\r
-+                      if (NativeLib.IsUnix())\r
-+                      {\r
-+                              strPath = Environment.GetFolderPath(Environment.SpecialFolder.CommonApplicationData);\r
-+                              strPath = UrlUtil.EnsureTerminatingSeparator(strPath, false);\r
-+                              strPath += PwDefs.ShortProductName.ToLower();\r
-+                              strPath = UrlUtil.EnsureTerminatingSeparator(strPath, false);\r
-+                      }\r
-+                      else\r
-+                      {\r
-+                              strPath = WinUtil.GetExecutable();\r
-+                              strPath = UrlUtil.GetFileDirectory(strPath, true, false);\r
-+                      }\r
-+\r
-                       strPath += AppDefs.XslFilesDir;\r
-                       strPath = UrlUtil.EnsureTerminatingSeparator(strPath, false);\r
-                       bool bInstalled = File.Exists(strPath + AppDefs.XslFileHtmlLite);\r
diff --git a/app-admin/keepass/files/keepass-2.35-new-monoprep-script.sh b/app-admin/keepass/files/keepass-2.35-new-monoprep-script.sh
deleted file mode 100644 (file)
index c6fc41f..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh
-
-buildDir="$(pwd)"
-keePassRootDir="${buildDir}/.."
-
-copyKeePassIcons()
-{
-    cd "${buildDir}"
-    cp -f ../Ext/Icons_04_CB/Finals2/plockb.ico ../KeePass/KeePass.ico
-    cp -f ../Ext/Icons_04_CB/Finals2/plockb.ico ../KeePass/Resources/Images/KeePass.ico
-}
-
-sanitizeKeePassProjectFiles()
-{
-    cd "${keePassRootDir}/KeePass"
-    
-    local keePassProjectFile="KeePass.csproj"
-    local keePassProjectSolution="KeePass.sln"
-   
-    sed -i 's!<SignAssembly>true</SignAssembly>!<SignAssembly>false</SignAssembly>!g' "${keePassProjectFile}"
-    sed -i 's! ToolsVersion="3.5"!!g' "${keePassProjectFile}"
-    sed -i '/sgen\.exe/d' "${keePassProjectFile}"
-    
-    # Update solution .NET format to 11 (This targets Mono 4 rather than 3.5)
-    cd "${keePassRootDir}"
-    sed -i 's!Format Version 10.00!Format Version 11.00!g' "${keePassProjectSolution}"
-    
-    cd "${buildDir}"
-}
-
-sanitizeKeePassLibProjectFile()
-{
-    cd "${keePassRootDir}/KeePassLib"
-    
-    local keePassProjectLibFile="KeePassLib.csproj"
-    sed -i 's!<SignAssembly>true</SignAssembly>!<SignAssembly>false</SignAssembly>!g' "${keePassProjectLibFile}"
-    sed -i 's! ToolsVersion="3.5"!!g' "${keePassProjectLibFile}"
-    
-    cd "${buildDir}"
-}
-
-
-sanitizeTrlUtilProjectFile()
-{
-    cd "${keePassRootDir}/Translation/TrlUtil"
-    
-    local trlUtilProjectFile="TrlUtil.csproj"
-    sed -i 's! ToolsVersion="3.5"!!g' "${trlUtilProjectFile}"
-    
-    cd "${buildDir}"
-}
-
-# Start
-copyKeePassIcons
-
-# Remove ToolsVersion 3.5 References so that newer Mono compilers can be used
-sanitizeKeePassProjectFiles
-sanitizeKeePassLibProjectFile
-sanitizeTrlUtilProjectFile
diff --git a/app-admin/keepass/keepass-2.35-r1.ebuild b/app-admin/keepass/keepass-2.35-r1.ebuild
deleted file mode 100644 (file)
index 0a4b7fe..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils fdo-mime gnome2-utils multilib
-
-MY_PN="KeePass"
-DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
-HOMEPAGE="http://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="aot"
-
-COMMON_DEPEND="dev-lang/mono"
-DEPEND="${COMMON_DEPEND}
-               app-arch/unzip"
-RDEPEND="${COMMON_DEPEND}
-               dev-dotnet/libgdiplus[cairo]"
-
-S="${WORKDIR}"
-PATCHES=( "${FILESDIR}/${PN}-2.20-xsl-path-detection.patch" )
-
-src_prepare() {
-       # KeePass looks for some XSL files in the same folder as the executable,
-       # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
-       # This XSL file will not be upstreamed since the KeePass creator said that
-       # including this patch would break the Portable USB version of KeePass
-       # (which keeps/looks for xsl files in its own folder)
-       default
-
-       # New Mono Prep Script until keepass 2.36+ comes out.
-       # This script has been upstreamed, still waiting for final confirmation.
-       local newMonoPrepScript="${FILESDIR}/keepass-2.35-new-monoprep-script.sh"
-
-       # Switch into build dir so the mono prepration script works correctly
-       cd Build || die
-       cp -f "${newMonoPrepScript}" PrepMonoDev.sh
-       source PrepMonoDev.sh || die
-       cd ../ || die
-}
-
-src_compile() {
-       # Build with Release target
-       xbuild /target:KeePass /property:Configuration=Release || die
-
-       # Run Ahead Of Time compiler on the binary
-       if use aot; then
-               cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
-               mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
-       fi
-}
-
-src_install() {
-       # Wrapper script to launch mono
-       make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
-
-       # Some XSL files
-       insinto "/usr/share/${PN}/XSL"
-       doins Ext/XSL/*
-
-       insinto "/usr/$(get_libdir)/${PN}/"
-       exeinto "/usr/$(get_libdir)/${PN}/"
-
-       doins Ext/KeePass.exe.config
-
-       # Default configuration, simply says to use user-specific configuration
-       doins Ext/KeePass.config.xml
-
-       # The actual executable
-       doexe Build/KeePass/Release/KeePass.exe
-
-       # Copy the AOT compilation result
-       if use aot; then
-               doexe Build/KeePass/Release/KeePass.exe.so
-       fi
-
-       # Prepare the icons
-       newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
-       newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
-
-       # Create a desktop entry and associate it with the KeePass mime type
-       make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;"
-
-       # MIME descriptor for .kdbx files
-       insinto /usr/share/mime/packages/
-       doins "${FILESDIR}/${PN}.xml"
-
-       # sed, because patching this really sucks
-       sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass"
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       _update_caches
-
-       if ! has_version x11-misc/xdotool ; then
-               elog "Optional dependencies:"
-               elog "  x11-misc/xdotool (enables autotype/autofill)"
-       fi
-
-       elog "Some systems may experience issues with copy and paste operations."
-       elog "If you encounter this, please install x11-misc/xsel."
-}
-
-pkg_postrm() {
-       _update_caches
-}
-
-_update_caches() {
-       gnome2_icon_cache_update
-       fdo-mime_mime_database_update
-       fdo-mime_desktop_database_update
-}