app-text/libmspub: Fix build with GCC 10, EAPI-7 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 9 May 2020 09:39:27 +0000 (11:39 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 9 May 2020 11:31:40 +0000 (13:31 +0200)
Thanks-to: cyrillic <cyrilmaley@hotmail.com>
Closes: https://bugs.gentoo.org/707762
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-text/libmspub/files/libmspub-0.1.4-gcc10.patch [new file with mode: 0644]
app-text/libmspub/libmspub-0.1.4.ebuild

diff --git a/app-text/libmspub/files/libmspub-0.1.4-gcc10.patch b/app-text/libmspub/files/libmspub-0.1.4-gcc10.patch
new file mode 100644 (file)
index 0000000..5e5d60e
--- /dev/null
@@ -0,0 +1,27 @@
+From 698bed839c9129fa7a90ca1b5a33bf777bc028d1 Mon Sep 17 00:00:00 2001
+From: Stephan Bergmann <sbergman@redhat.com>
+Date: Tue, 11 Jun 2019 12:15:28 +0200
+Subject: missing include
+
+Change-Id: I3c5c085f55223688cdc7b972f7c7981411881263
+Reviewed-on: https://gerrit.libreoffice.org/73814
+Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
+Tested-by: Michael Stahl <Michael.Stahl@cib.de>
+---
+ src/lib/MSPUBMetaData.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/lib/MSPUBMetaData.h b/src/lib/MSPUBMetaData.h
+index 9167f4f..27bdd4f 100644
+--- a/src/lib/MSPUBMetaData.h
++++ b/src/lib/MSPUBMetaData.h
+@@ -13,6 +13,7 @@
+ #include <map>
+ #include <utility>
+ #include <vector>
++#include <stdint.h>
+ #include <librevenge/librevenge.h>
+-- 
+cgit v1.2.1
index 536dfc3cfcd70b9e57a05ebf58ed68bcb78469d7..20eba626a22a214d3ae1903f145722f30df50376 100644 (file)
@@ -1,26 +1,28 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit flag-o-matic
 
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
-
+if [[ ${PV} = *9999 ]]; then
+       EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
+       inherit autotools git-r3
+else
+       SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
+       KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86"
+fi
 DESCRIPTION="Library parsing Microsoft Publisher documents"
 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
-[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
 
 LICENSE="LGPL-2.1"
 SLOT="0"
-
-# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86"
-
 IUSE="doc static-libs"
 
+BDEPEND="
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )
+"
 RDEPEND="
        dev-libs/icu:=
        dev-libs/librevenge
@@ -29,27 +31,29 @@ RDEPEND="
 DEPEND="${RDEPEND}
        dev-libs/boost
        sys-devel/libtool
-       virtual/pkgconfig
-       doc? ( app-doc/doxygen )
 "
 
+PATCHES=( "${FILESDIR}/${P}-gcc10.patch" )
+
 src_prepare() {
        default
        [[ -d m4 ]] || mkdir "m4"
-       [[ ${PV} == 9999 ]] && eautoreconf
+       [[ ${PV} == *9999 ]] && eautoreconf
 }
 
 src_configure() {
        # bug 619044
        append-cxxflags -std=c++14
 
-       econf \
-               --disable-werror \
-               $(use_with doc docs) \
+       local myeconfargs=(
+               --disable-werror
+               $(use_with doc docs)
                $(use_enable static-libs static)
+       )
+       econf "${myeconfargs[@]}"
 }
 
 src_install() {
        default
-       find "${D}" -name '*.la' -delete || die
+       find "${D}" -name '*.la' -type f -delete || die
 }