dev-tex/currvita: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 22:20:51 +0000 (17:20 -0500)
committerAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 22:21:20 +0000 (17:21 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-tex/currvita/currvita-0.9i-r1.ebuild

index 3e4bb3afa652b6a15f6a09c6cc21e7b80e59eaa6..bbec7ac34cdbe314ffc56da0f5afe4505f39823c 100644 (file)
@@ -1,33 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit latex-package
 
 DESCRIPTION="A LaTeX package for typesetting a curriculum vitae"
-HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/currvita/"
+HOMEPAGE="https://www.ctan.org/tex-archive/macros/latex/contrib/currvita/"
 # snapshot taken from
 # ftp://ftp.dante.de/tex-archive/macros/latex/contrib/currvita.tar.gz
 SRC_URI="mirror://gentoo/${P}.tar.gz"
 
-LICENSE="GPL-2"
-SLOT="0"
 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 
+LICENSE="GPL-2"
+SLOT="0"
 IUSE=""
 
 DEPEND="dev-texlive/texlive-langgerman"
 RDEPEND="${DEPEND}"
 
-S="${WORKDIR}/${PN}"
-
 TEXMF="/usr/share/texmf-site"
-DOCS="README"
+
+DOCS=( "README" )
+
+S="${WORKDIR}/${PN}"
 
 src_test() {
-       latex currvita.dtx || die "first step of currvita.dtx failed"
-       latex currvita.dtx || die "second step of currvita.dtx failed"
-       latex currvita.dtx || die "third step of currvita.dtx failed"
-       latex cvtest.tex || die "processing cvtest.tex failed"
+       latex currvita.dtx || die "first test of currvita.dtx failed"
+       latex currvita.dtx || die "second test of currvita.dtx failed"
+       latex currvita.dtx || die "third test of currvita.dtx failed"
+       latex cvtest.tex || die "test of cvtest.tex failed"
 }