dev-python/pyyaml: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:17:42 +0000 (22:17 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:24:51 +0000 (22:24 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyyaml/Manifest
dev-python/pyyaml/pyyaml-3.12.ebuild [deleted file]

index 0757ac8875261dfa8ac65afa816951bd6dd7b90d..a15eb5fdb2552a16998bad9da4da1736e2191c8e 100644 (file)
@@ -1,4 +1,3 @@
-DIST PyYAML-3.12.tar.gz 253011 BLAKE2B 530f2910acb757af9e2a738d93ace45daee3fc5764f19fbc758508e873f05ebfa2486c4f82800540e5e405e7f114f06f963e5011908fd15014ca8b8afb3a76aa SHA512 e16d8b7f4f026b6a95b11fb59c54ec5f114f6f516294eaa95e718abdf5d37c17a9c4b5e0a0a61fca04e801792d9b7fb801087cf849ff22b9581f6af204b1883a
 DIST PyYAML-3.13.tar.gz 270607 BLAKE2B f365f63587b911234497426c9796f98b85f5de052abd88ea434137a4eb8a4c1e08f9ee1982a30df1934dadb615145f4af8fcff577d3d4e52058e7a8843aa8604 SHA512 93642286d0317e2fe970632c36d38ce6030f7cabcf971f28e3a1054f07390fcee5baaf7f167e7c9690dbd7b2adc61f5b7d75a218ace0abca34ff8815486cfdd7
 DIST PyYAML-5.1.2.tar.gz 265034 BLAKE2B a3f6fe4a0c0a24f8934b94545e7727fad26b397755416a8127bd52fd9ea5e8fea3c6452ddfbd91edfa2e8ca88522b1ae9061c9221f394c8fa4cbd1c2dc256f72 SHA512 b5ee201c612486a95c87b7e41d474313160284359b8b30ababc80b51325aef9dd7dc27eb3b8a03a4749cb8c7e3789c5684d5c285fe35d4b20be1f189641531e0
 DIST PyYAML-5.1.tar.gz 274244 BLAKE2B ea8cc4b56b9fc70bc7b01f8c654ceb8b73c82dcc936c939cba3c3654df04fe32fc46c7df322a38869d28ad5a58f6134b35cbe43924df3b4d5f3e54e33700dc73 SHA512 8f27f92bdfa310a99dd6d83947332cc033fa18f0011998bb585ad5c4340a2da20d8c20bfdb53beaae15651198d1240c986818379b0a05b230f74d1f30f53e7fd
diff --git a/dev-python/pyyaml/pyyaml-3.12.ebuild b/dev-python/pyyaml/pyyaml-3.12.ebuild
deleted file mode 100644 (file)
index d901939..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-MY_P="PyYAML-${PV}"
-
-DESCRIPTION="YAML parser and emitter for Python"
-HOMEPAGE="https://pyyaml.org/wiki/PyYAML https://pypi.org/project/PyYAML/"
-SRC_URI="https://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="examples libyaml"
-
-RDEPEND="libyaml? ( dev-libs/libyaml )"
-DEPEND="${RDEPEND}
-       libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_configure_all() {
-       mydistutilsargs=( $(use_with libyaml) )
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       if use examples; then
-               dodoc -r examples
-               docompress -x /usr/share/doc/${PF}
-       fi
-}