dev-perl/App-perlbrew: Bump to version 0.880.0
authorKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 11:38:35 +0000 (23:38 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 11:39:02 +0000 (23:39 +1200)
- EAPI7
- Improve handling and documentation of network tests

Upstream:
- Fix 'clone-modules'
- Fix error from 'install' command.
- Tweak seperator of 'exec' command.
- Use new official repo for fetching blead perl
- Add --min and --max options to 'exec' command
- Fix "ERROR: Cannot find the tarball for perl-$version"
- Fix calling patchperl on readonly files
- Fix installation from local tarball files
- "install" command now shows error message from http_download
- ".tar.bz2" suffix no longer displayed with 'available' command

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/App-perlbrew/App-perlbrew-0.880.0.ebuild [new file with mode: 0644]
dev-perl/App-perlbrew/Manifest
dev-perl/App-perlbrew/metadata.xml

diff --git a/dev-perl/App-perlbrew/App-perlbrew-0.880.0.ebuild b/dev-perl/App-perlbrew/App-perlbrew-0.880.0.ebuild
new file mode 100644 (file)
index 0000000..4a16bac
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GUGOD
+DIST_VERSION=0.88
+inherit perl-module
+
+DESCRIPTION='Manage perl installations in your $HOME'
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=virtual/perl-ExtUtils-MakeMaker-6.860.0
+       >=dev-perl/CPAN-Perl-Releases-5.201.912.200
+       >=dev-perl/Capture-Tiny-0.360.0
+       >=dev-perl/Devel-PatchPerl-1.800.0
+       >=virtual/perl-ExtUtils-MakeMaker-7.220.0
+       >=virtual/perl-File-Temp-0.230.400
+       virtual/perl-JSON-PP
+       >=virtual/perl-Pod-Parser-1.630.0
+       >=dev-perl/local-lib-2.0.14
+"
+DEPEND="
+       dev-perl/Module-Build-Tiny
+"
+BDEPEND="${RDEPEND}
+       >=dev-perl/Module-Build-Tiny-0.34.0
+       test? (
+               >=dev-perl/File-Which-1.210.0
+               >=dev-perl/IO-All-0.510.0
+               >=dev-perl/Path-Class-0.330.0
+
+               >=dev-perl/Test-Exception-0.320.0
+               >=dev-perl/Test-NoWarnings-1.40.0
+               >=dev-perl/Test-Output-1.30.0
+               >=virtual/perl-Test-Simple-1.1.2
+               >=dev-perl/Test-Spec-0.470.0
+               >=dev-perl/Test-TempDir-Tiny-0.16.0
+       )
+"
+mydoc=("doc/notes.org")
+src_test() {
+       ( # export leak guard
+               if has "network" ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+                       einfo "Network Tests Enabled"
+                       export TEST_LIVE=1
+               else
+                       ewarn "This package needs network access for comprehensive testing."
+                       ewarn "For details, see:"
+                       ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+               fi
+               if has "network-dev-test" ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+                       einfo "Developer HTTP Test enabled"
+                       export PERLBREW_DEV_TEST=1
+               fi
+               perl-module_src_test
+       )
+}
index 6a1902c62042df7f6fe94aa376b7df355b68d53b..3300b7cfd8f884a462685883b79628a715f3b87d 100644 (file)
@@ -1 +1,2 @@
 DIST App-perlbrew-0.84.tar.gz 83189 BLAKE2B 06d1a33c6d564c380a585e9f859e9a2c4b3df5bf32dff9b8b0e80069b77ccd60058b2a2d8fda15624fda399b26daa24643dba32090541176553400eb176c5761 SHA512 2e283a6e6f6c4ca78a50548ad80b91f5f5b791bcd46ce1881037e3c1bb52c1863879c978cb621c55ec26fc97d24163c4f710812c0fef868cd6dd3ebc2aa1eb0c
+DIST App-perlbrew-0.88.tar.gz 92126 BLAKE2B f7bff0635d9d3d768f781ffd0f67c69db4d837b7f2dffc72a002c3dee4ea2e7cc04b1e4ed46e68e52d675859516b88832be563f8cdfa35d6dc6cccc875ecf265 SHA512 16a60637f9de4ca12b270b3a6946b15b0881af797e5f811be601895ed25db0eb98f6056a219025213f439ceb5f2253bb175e0efa5d3742fffd7820fcf0433115
index ff5b76db121c5cb5dc152a988fd9f768b3221b27..6073ef84ff9733fe858341dfc9a13315827bb62f 100644 (file)
@@ -7,6 +7,11 @@
     </maintainer>
     <upstream>
         <remote-id type="cpan">App-perlbrew</remote-id>
+        <remote-id type="cpan-module">App::Perlbrew::Path</remote-id>
+        <remote-id type="cpan-module">App::Perlbrew::Path::Installation</remote-id>
+        <remote-id type="cpan-module">App::Perlbrew::Path::Installations</remote-id>
+        <remote-id type="cpan-module">App::Perlbrew::Path::Root</remote-id>
+        <remote-id type="cpan-module">App::Perlbrew::Util</remote-id>
         <remote-id type="cpan-module">App::perlbrew</remote-id>
     </upstream>
 </pkgmetadata>