media-libs/x264: bump a new snapshot, api 157
authorAlexis Ballier <aballier@gentoo.org>
Fri, 15 Feb 2019 11:45:41 +0000 (12:45 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 15 Feb 2019 12:35:53 +0000 (13:35 +0100)
Closes: https://bugs.gentoo.org/676596
Package-Manager: Portage-2.3.60, Repoman-2.3.12
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
media-libs/x264/Manifest
media-libs/x264/x264-0.0.20190214.ebuild [new file with mode: 0644]

index 0a6d855801626e5ad1b3e204081f165363688204..ab3b20f239251c65d087bef067f9e659ecc15387 100644 (file)
@@ -1 +1,2 @@
 DIST x264-snapshot-20170701-2245.tar.bz2 750527 BLAKE2B ccf276da31383ab4b4a1ac48866bc49b4b2bc5913361c933fa2359de4d6e90cca091dd4aba781f3735a5b28d6ce006aa9d4e149ba48745b80cb971c2952ca867 SHA512 28fc9850c36ac385fced6dec9a0f68a5605a68805e1ef7b8cedcd78917eaa1ad6e47e57fe5a74fee0a6e482f3a33de6011f675e6c77b5db94c8fe01d5c5f3e9f
+DIST x264-snapshot-20190214-2245.tar.bz2 770462 BLAKE2B d90a3bafb88febe12526b225617616a62c32fa3d3eacf410267e1fbd7e0fafaadca7c146172c08fc525bce8791d81c7d87dc27b06d61a6a44bf2ad92f6c1def6 SHA512 c8b1b46d4e6c0ef653dab35083a454c635ebf72c6a5255ce30bbb5d9d6bb8e23fca0e6cc197ea99f3c702fbfec096587df6fa82dec338d8bd45e35fa89c43039
diff --git a/media-libs/x264/x264-0.0.20190214.ebuild b/media-libs/x264/x264-0.0.20190214.ebuild
new file mode 100644 (file)
index 0000000..0128bcd
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multilib-minimal toolchain-funcs
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="https://www.videolan.org/developers/x264.html"
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://git.videolan.org/git/x264.git"
+else
+       MY_P="x264-snapshot-$(ver_cut 3)-2245"
+       SRC_URI="https://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+       S="${WORKDIR}/${MY_P}"
+fi
+
+SLOT="0/157" # SONAME
+
+LICENSE="GPL-2"
+IUSE="altivec +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
+
+ASM_DEP=">=dev-lang/nasm-2.13"
+DEPEND="abi_x86_32? ( ${ASM_DEP} )
+       abi_x86_64? ( ${ASM_DEP} )
+       opencl? ( dev-lang/perl )"
+RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )"
+
+DOCS=( AUTHORS doc/{ratecontrol,regression_test,standards,threads,vui}.txt )
+
+multilib_src_configure() {
+       tc-export CC
+       local asm_conf=""
+
+       if [[ ${ABI} == x86* ]] && { use pic || use !cpu_flags_x86_sse ; } || [[ ${ABI} == "x32" ]] || [[ ${CHOST} == armv5* ]] || [[ ${ABI} == ppc* ]] && { use !altivec ; }; then
+               asm_conf=" --disable-asm"
+       fi
+
+       "${S}/configure" \
+               --prefix="${EPREFIX}"/usr \
+               --libdir="${EPREFIX}"/usr/$(get_libdir) \
+               --disable-cli \
+               --disable-avs \
+               --disable-lavf \
+               --disable-swscale \
+               --disable-ffms \
+               --disable-gpac \
+               --enable-pic \
+               --enable-shared \
+               --host="${CHOST}" \
+               $(usex interlaced "" "--disable-interlaced") \
+               $(usex opencl "" "--disable-opencl") \
+               $(usex static-libs "--enable-static" "") \
+               $(usex threads "" "--disable-thread") \
+               ${asm_conf} || die
+}