sci-physics/lammps: add kokkos support
authorChristoph Junghans <junghans@gentoo.org>
Sun, 15 Mar 2020 13:36:50 +0000 (07:36 -0600)
committerChristoph Junghans <junghans@gentoo.org>
Sun, 15 Mar 2020 13:37:13 +0000 (07:37 -0600)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Christoph Junghans <junghans@gentoo.org>
sci-physics/lammps/lammps-20200303.ebuild
sci-physics/lammps/metadata.xml

index 025056ed13016415a42e0d1520187639b16f9ed1..b159bd9a94699733f6f9373d56c93d17d77536ab 100644 (file)
@@ -23,7 +23,7 @@ SRC_URI="https://github.com/lammps/lammps/archive/${MY_PV}.tar.gz -> ${MY_P}.tar
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="cuda examples gzip lammps-memalign mpi netcdf python test"
+IUSE="cuda examples gzip kokkos lammps-memalign mpi netcdf python test"
 RESTRICT="!test? ( test )"
 
 DEPEND="
@@ -41,6 +41,7 @@ DEPEND="
        sci-libs/fftw:3.0
        netcdf? ( sci-libs/netcdf )
        cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
+       kokkos? ( >=dev-cpp/kokkos-3.0.00 )
        dev-cpp/eigen:3
        "
 RDEPEND="${DEPEND}"
@@ -69,6 +70,8 @@ src_configure() {
                -DPKG_GRANULAR=ON
                -DPKG_KSPACE=ON
                -DFFT=FFTW3
+               -DPKG_KOKKOS=$(usex kokkos)
+               $(use kokkos && echo -DEXTERNAL_KOKKOS=ON)
                -DPKG_MANYBODY=ON
                -DPKG_MC=ON
                -DPKG_MEAM=ON
index be0e36d7abee7789af861abd05a472c3fe811de2..274aacacf7b64b3f5dc05c76cbe5e94dfdab3c3b 100644 (file)
@@ -20,6 +20,7 @@
                        call instead of malloc() when large chunks or memory are allocated
                        by LAMMPS. Aliengnment is on 16 byte boundaries.</flag>
                <flag name="cuda">Enable cuda non-bonded kernels</flag>
+               <flag name="kokkos">Enable kokkos non-bonded kernels</flag>
        </use>
        <maintainer type="person">
                <email>nicolasbock@gentoo.org</email>