dev-python/css-parser: Update PYTHON_COMPAT
authorZac Medico <zmedico@gentoo.org>
Sun, 26 Apr 2020 23:17:47 +0000 (16:17 -0700)
committerZac Medico <zmedico@gentoo.org>
Sun, 26 Apr 2020 23:19:12 +0000 (16:19 -0700)
Bug: https://bugs.gentoo.org/710390
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Zac Medico <zmedico@gentoo.org>
dev-python/css-parser/css-parser-1.0.4-r1.ebuild

index 6e64e14284fea69e83e16de5f021f36b63652141..16d755705e6f7021a820aecb38a9dd640817d03a 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit distutils-r1
 
@@ -15,3 +15,9 @@ SLOT="0"
 KEYWORDS="amd64 ~arm x86"
 
 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# Tests fail under network-sandbox.
+RESTRICT+=" test"
+
+python_test() {
+       esetup.py test || die "tests failed under ${EPYTHON}"
+}