net-ftp/proftpd: tweak for gcc-10
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 2 Mar 2020 23:40:18 +0000 (23:40 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 2 Mar 2020 23:40:49 +0000 (23:40 +0000)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-ftp/proftpd/files/proftpd-1.3.6c-gcc-10.patch [new file with mode: 0644]
net-ftp/proftpd/proftpd-1.3.6c.ebuild

diff --git a/net-ftp/proftpd/files/proftpd-1.3.6c-gcc-10.patch b/net-ftp/proftpd/files/proftpd-1.3.6c-gcc-10.patch
new file mode 100644 (file)
index 0000000..c3ee704
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/contrib/mod_quotatab.c
++++ b/contrib/mod_quotatab.c
+@@ -50,6 +50,7 @@ typedef struct regtab_obj {
+ module quotatab_module;
+ /* Quota objects for the current session */
++quota_deltas_t quotatab_deltas;
+ static quota_table_t *limit_tab = NULL;
+ static quota_limit_t sess_limit;
+--- a/contrib/mod_quotatab.h
++++ b/contrib/mod_quotatab.h
+@@ -188,7 +188,7 @@ typedef struct table_obj {
+ #define QUOTATAB_TALLY_SRC      0x0002
+ /* Quota objects for the current session. */
+-quota_deltas_t quotatab_deltas;
++extern quota_deltas_t quotatab_deltas;
+ /* Function prototypes necessary for quotatab sub-modules */
+ int quotatab_log(const char *, ...)
index 5c8f9eb610d33b8ce070ab2fab40ff0c518de653..d2441f41e29c047de2a8b3f4ecfdfc921df9e34d 100644 (file)
@@ -71,6 +71,7 @@ S="${WORKDIR}/${P/_/}"
 PATCHES=(
        "${FILESDIR}"/${PN}-1.3.6-use-trace.patch
        "${FILESDIR}"/${PN}-1.3.6a-fix-libcheck.patch
+       "${FILESDIR}"/${PN}-1.3.6c-gcc-10.patch
 )
 
 RESTRICT=test # tests corrupt memory. need to be fixed upstream first