-diff -Naur xml-xalan.orig/c/src/xalanc/Makefile.in xml-xalan/c/src/xalanc/Makefile.in
---- xml-xalan.orig/c/src/xalanc/Makefile.in 2009-07-27 00:23:08.411122528 +0200
-+++ xml-xalan/c/src/xalanc/Makefile.in 2009-07-27 00:45:09.514777553 +0200
+--- a/src/xalanc/Makefile.in
++++ b/src/xalanc/Makefile.in
@@ -174,7 +174,7 @@
"//'$(LOADSAMP)(${BATCH_XALAN_UTIL_NAME})'": ${XSL_OBJ_DIR}/XalanExe.o
ifeq ($(PLATFORM), OS390)
mv *.x ${XSL_LIB_DIR}
else
-diff -Naur xml-xalan.orig/c/src/xalanc/Utils/MsgCreator/Makefile.in xml-xalan/c/src/xalanc/Utils/MsgCreator/Makefile.in
---- xml-xalan.orig/c/src/xalanc/Utils/MsgCreator/Makefile.in 2009-07-27 00:23:08.431122558 +0200
-+++ xml-xalan/c/src/xalanc/Utils/MsgCreator/Makefile.in 2009-07-27 00:43:47.674693543 +0200
+--- a/src/xalanc/Utils/MsgCreator/Makefile.in
++++ b/src/xalanc/Utils/MsgCreator/Makefile.in
@@ -29,7 +29,7 @@
$(XSL_BIN_DIR)/MsgCreator : $(MSG_CREATOR_OBJECTS)
$(XSL_OBJ_DIR)/%.o : $(MSG_CREATOR_SRC)/%.cpp
$(CC1) $(XSL_BUILD_OPTIONS) -c $(XSL_INCL) $(EXTRA_COMPILE_OPTIONS) -o $@ $<
-diff -Naur xml-xalan.orig/c/Tests/Makefile.in xml-xalan/c/Tests/Makefile.in
---- xml-xalan.orig/c/Tests/Makefile.in 2009-07-27 00:23:08.514445103 +0200
-+++ xml-xalan/c/Tests/Makefile.in 2009-07-27 00:45:50.541094978 +0200
+--- a/Tests/Makefile.in
++++ b/Tests/Makefile.in
@@ -62,7 +62,7 @@
$(XSL_BIN_DIR)/ThreadTest: ${XSL_OBJ_DIR}/ThreadTest.o
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit toolchain-funcs eutils multilib
+inherit toolchain-funcs
DESCRIPTION="XSLT processor for transforming XML into HTML, text, or other XML types"
-HOMEPAGE="http://xml.apache.org/xalan-c/"
+HOMEPAGE="https://xml.apache.org/xalan-c/"
SRC_URI="mirror://gentoo/Xalan-C_r${PV#*_pre}-src.tar.gz"
LICENSE="Apache-2.0"
IUSE="doc examples nls threads"
RDEPEND=">=dev-libs/xerces-c-2.8.0"
-# icu? ( dev-libs/icu )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )"
S="${WORKDIR}/xml-xalan/c"
-pkg_setup() {
-# export ICUROOT="/usr"
- export XALANCROOT="${S}"
-}
+PATCHES=(
+ "${FILESDIR}"/1.11.0_pre797991-as-needed.patch
+ "${FILESDIR}"/1.11.0_pre797991-bugfixes.patch
+ "${FILESDIR}"/1.11.0_pre797991-parallel-build.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}/1.11.0_pre797991-as-needed.patch" \
- "${FILESDIR}/1.11.0_pre797991-bugfixes.patch" \
- "${FILESDIR}/1.11.0_pre797991-parallel-build.patch"
+ default
# - do not run configure in runConfigure
# - echo the export commands instead exporting the vars
src_configure() {
export XERCESCROOT="/usr"
+ export XALANCROOT="${S}"
local target="linux"
- # add more if needed, see xerces-c-2.8.0-r1 ebuild
-
- local mloader="inmem"
- use nls && mloader="nls"
-# use icu && mloader="icu"
-
local transcoder="default"
-# use icu && transcoder="icu"
-
- local thread="none"
- use threads && thread="pthread"
+ local mloader=$(usex nls nls inmem)
+ local thread=$(usex threads pthread none)
./runConfigure -p ${target} -c "$(tc-getCC)" -x "$(tc-getCXX)" \
-m ${mloader} -t ${transcoder} \
src_compile() {
default
- if use doc ; then
- mkdir build
- cd "${S}/xdocs"
- doxygen DoxyfileXalan
+ if use doc; then
+ mkdir build || die
+ cd xdocs || die
+ doxygen DoxyfileXalan || die
+ HTML_DOCS=( build/docs/apiDocs/. )
+
+ # clean doxygen cruft
+ find "${S}"/build \( -iname '*.map' -o -iname '*.md5' \) -delete || die
fi
}
src_install() {
default
- if use doc ; then
- dodir /usr/share/doc/${PF}
- dohtml -r build/docs/apiDocs/*
- fi
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins -r samples/*
+ if use examples; then
+ docinto examples
+ dodoc -r samples/.
fi
}