app-crypt/trousers: Fix -fno-common/gcc10 compile error
authorSalah Coronya <salah.coronya@gmail.com>
Sat, 25 Apr 2020 04:03:52 +0000 (23:03 -0500)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 28 Apr 2020 07:44:06 +0000 (10:44 +0300)
Closes: https://bugs.gentoo.org/707244
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Salah Coronya <salah.coronya@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15509
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-crypt/trousers/files/trousers-0.3.14-fno-common.patch [new file with mode: 0644]
app-crypt/trousers/trousers-0.3.14-r2.ebuild

diff --git a/app-crypt/trousers/files/trousers-0.3.14-fno-common.patch b/app-crypt/trousers/files/trousers-0.3.14-fno-common.patch
new file mode 100644 (file)
index 0000000..5046bc7
--- /dev/null
@@ -0,0 +1,15 @@
+diff --git a/src/include/tcsd.h b/src/include/tcsd.h
+index 5b9462b..05bae97 100644
+--- a/src/include/tcsd.h
++++ b/src/include/tcsd.h
+@@ -166,8 +166,8 @@ void          thread_signal_init();
+ /* signal handling */
+ #ifndef __APPLE__
+-struct sigaction tcsd_sa_int;
+-struct sigaction tcsd_sa_chld;
++extern struct sigaction tcsd_sa_int;
++extern struct sigaction tcsd_sa_chld;
+ #endif
+ #endif
index 98591153d5612231cf056bc7b8ad02bd6dc9f09a..b94cc955e2d7956376fdca9c51b43a656dea6c96 100644 (file)
@@ -29,6 +29,7 @@ BDEPEND="virtual/pkgconfig"
 PATCHES=(
        "${FILESDIR}/${PN}-0.3.13-nouseradd.patch"
        "${FILESDIR}/${P}-libressl.patch"
+       "${FILESDIR}/${P}-fno-common.patch"
 )
 
 DOCS="AUTHORS ChangeLog NICETOHAVES README TODO"
@@ -37,45 +38,9 @@ DOC_CONTENTS="
        If you have problems starting tcsd, please check permissions and
        ownership on /dev/tpm* and ~tss/system.data
 "
-
 S="${WORKDIR}"
 
-pkg_setup() {
-       # Check for driver (not sure it can be an rdep, because ot depends on the
-       # version of virtual/linux-sources... Is that supported by portage?)
-       linux-info_pkg_setup
-       local tpm_kernel_version tpm_kernel_present tpm_module
-       kernel_is ge 2 6 12 && tpm_kernel_version="yes"
-       if linux_config_exists; then
-               linux_chkconfig_present TCG_TPM && tpm_kernel_present="yes"
-       else
-               ewarn "No kernel configuration could be found."
-       fi
-       has_version app-crypt/tpm-emulator && tpm_module="yes"
-       if [[ -n "${tpm_kernel_present}" ]]; then
-               einfo "Good, you seem to have in-kernel TPM support."
-       elif [[ -n "${tpm_module}" ]]; then
-               einfo "Good, you seem to have TPM support with the external module."
-               if [[ -n "${tpm_kernel_version}" ]]; then
-                       elog
-                       elog "Note that since you have a >=2.6.12 kernel, you could use"
-                       elog "the in-kernel driver instead of (CONFIG_TCG_TPM)."
-               fi
-       elif [[ -n "${tpm_kernel_version}" ]]; then
-               eerror
-               eerror "To use this package, you will have to activate TPM support"
-               eerror "in your kernel configuration. That's at least CONFIG_TCG_TPM,"
-               eerror "plus probably a chip specific driver (like CONFIG_TCG_ATMEL)."
-               eerror
-       else
-               eerror
-               eerror "To use this package, you should install a TPM driver."
-               eerror "You can have the following options:"
-               eerror "  - install app-crypt/tpm-emulator"
-               eerror "  - switch to a >=2.6.12 kernel and compile the kernel module"
-               eerror
-       fi
-}
+CONFIG_CHECK="~TCG_TPM"
 
 src_prepare() {
        default