dev-python/cmd2: Use virtx to reenable selection buffer tests
authorMichał Górny <mgorny@gentoo.org>
Tue, 9 Jul 2019 20:00:26 +0000 (22:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 9 Jul 2019 20:00:26 +0000 (22:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cmd2/cmd2-0.9.14.ebuild

index 4436ff15f8fbc30aa47ef9295a485d1543db5700..5901eaf47db5b30e9b59e8f55d7f39c3885bbeac 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 PYTHON_COMPAT=( python{3_5,3_6,3_7} )
 
-inherit distutils-r1
+inherit distutils-r1 virtualx
 
 DESCRIPTION="Extra features for standard library's cmd module"
 HOMEPAGE="https://github.com/python-cmd2/cmd2"
@@ -32,15 +32,12 @@ DEPEND="
        )
 "
 
-python_prepare_all() {
-       # disable test relying on paste buffer
-       sed -i -e 's:test_send_to_paste_buffer:_&:' tests/test_cmd2.py || die
-
-       distutils-r1_python_prepare_all
-}
-
 python_test() {
        # test rely on very specific text wrapping...
        local -x COLUMNS=80
        pytest -vv || die
 }
+
+src_test() {
+       virtx distutils-r1_src_test
+}