dev-util/dwarves: version bumped
authorMatthias Schwarzott <zzam@gentoo.org>
Mon, 16 Dec 2019 20:10:31 +0000 (21:10 +0100)
committerMatthias Schwarzott <zzam@gentoo.org>
Mon, 16 Dec 2019 20:13:55 +0000 (21:13 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Matthias Schwarzott <zzam@gentoo.org>
dev-util/dwarves/Manifest
dev-util/dwarves/dwarves-1.16.ebuild [new file with mode: 0644]

index e6da8f319a32a5e2e3f001039f0199c15678f88b..16d80c30b2ef8086ca782d1b69804961d1082002 100644 (file)
@@ -1,3 +1,4 @@
 DIST dwarves-1.12.tar.bz2 112400 BLAKE2B e71051041dfdbefc603dc041303de82e2e44c8b0f4f888577722466aaf7958cab7b04c15154faa8cbfcaa44fe60fc549e09b2fb68747cc3cdd08b8bce487cfdf SHA512 20644344e694253b79ede65e489696a319f10eaf424af81882414ae6efeaf34a82132321430d647916b78f97ef504907b3bd32919420f2cd14384910e283ff27
 DIST dwarves-1.13.tar.xz 222008 BLAKE2B db73f5c9a319a1a57ef37127350a9da117e3f5c89e199445393e3e312139ce8f88f46e6e5bbf302d708c0b075b1c2b2cd75dc7bc213ed144d1db792c55358220 SHA512 26485b183b4c7b608dd0392f9155dd570a14c86fdeafee232e44ad30f14a1357b408b61b0e8a31ea4bf976ed7fc44e7d5a4a3ccede9713c47265ad52c13dadf0
 DIST dwarves-1.15.tar.xz 222272 BLAKE2B a33d128ec899da0f0a1e2fc96703f0425fd1a2082675ddf886df55507b29b5fbad1a1cefd6b0a9002f50193b4c70f87a2eeacd50d94388776bb338fe678849e0 SHA512 29a8a15b7190480e79c2f423c7104d0fd275cd4c3df17518a1dd3c63cce1c528fad4b6f580baa397d9aa9323703009009e2d529939b12dd1af2c65cf7120b237
+DIST dwarves-1.16.tar.xz 273060 BLAKE2B a4cd976ff1cf6af0e2848a337400f4b1961ec5aff528d1c5893053967c0d1e7fc77de8220ae67c4b8a3eb387b659fbfd72113b29b2bf6a20d1fc45a59008a3e0 SHA512 6d57b26db70736353d8797d1f7d68c7c73b6df3ae69eb66dd7cb07d6b50a26c4f2adaa576a8915a4a7f8c41b67dcebbfc8cbdf3ba507dbf941f63941b13d65b1
diff --git a/dev-util/dwarves/dwarves-1.16.ebuild b/dev-util/dwarves/dwarves-1.16.ebuild
new file mode 100644 (file)
index 0000000..d4a49fb
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+inherit multilib cmake-utils python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+       >=dev-libs/elfutils-0.131
+       <=dev-libs/elfutils-0.177
+       sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+       SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.xz"
+       S=${WORKDIR}
+else
+       SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+PATCHES=( "${FILESDIR}"/${PN}-1.10-python-import.patch )
+
+src_configure() {
+       local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+       cmake-utils_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+       cmake-utils_src_install
+}