Version bump for rails 1.2.3.
authorJoshua Nichols <nichoj@gentoo.org>
Wed, 14 Mar 2007 04:27:24 +0000 (04:27 +0000)
committerJoshua Nichols <nichoj@gentoo.org>
Wed, 14 Mar 2007 04:27:24 +0000 (04:27 +0000)
Package-Manager: portage-2.1.2-r12

18 files changed:
dev-ruby/actionmailer/ChangeLog
dev-ruby/actionmailer/actionmailer-1.3.3.ebuild [new file with mode: 0644]
dev-ruby/actionmailer/files/digest-actionmailer-1.3.3 [new file with mode: 0644]
dev-ruby/actionpack/ChangeLog
dev-ruby/actionpack/actionpack-1.13.3.ebuild [new file with mode: 0644]
dev-ruby/actionpack/files/digest-actionpack-1.13.3 [new file with mode: 0644]
dev-ruby/actionwebservice/ChangeLog
dev-ruby/actionwebservice/actionwebservice-1.2.3.ebuild [new file with mode: 0644]
dev-ruby/actionwebservice/files/digest-actionwebservice-1.2.3 [new file with mode: 0644]
dev-ruby/activerecord/ChangeLog
dev-ruby/activerecord/activerecord-1.15.3.ebuild [new file with mode: 0644]
dev-ruby/activerecord/files/digest-activerecord-1.15.3 [new file with mode: 0644]
dev-ruby/activesupport/ChangeLog
dev-ruby/activesupport/activesupport-1.4.2.ebuild [new file with mode: 0644]
dev-ruby/activesupport/files/digest-activesupport-1.4.2 [new file with mode: 0644]
dev-ruby/rails/ChangeLog
dev-ruby/rails/files/digest-rails-1.2.3 [new file with mode: 0644]
dev-ruby/rails/rails-1.2.3.ebuild [new file with mode: 0644]

index 895cefb9e629ef98e707e6dfc69bdfd75d23c341..4e6b68b9f9af73904eb7cec044b25d39a20eab1b 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/actionmailer
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.52 2007/03/04 20:31:36 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.53 2007/03/14 04:22:06 nichoj Exp $
+
+*actionmailer-1.3.3 (14 Mar 2007)
+
+  14 Mar 2007; Joshua Nichols <nichoj@gentoo.org>
+  +actionmailer-1.3.3.ebuild:
+  Version bump for rails 1.2.3.
 
   04 Mar 2007; Tom Gall <tgall@gentoo.org> actionmailer-1.3.2.ebuild:
   added ~ppc64
diff --git a/dev-ruby/actionmailer/actionmailer-1.3.3.ebuild b/dev-ruby/actionmailer/actionmailer-1.3.3.ebuild
new file mode 100644 (file)
index 0000000..5cdec8d
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-1.3.3.ebuild,v 1.1 2007/03/14 04:22:06 nichoj Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="1.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="=dev-ruby/actionpack-1.13.3
+       >=dev-lang/ruby-1.8.5"
diff --git a/dev-ruby/actionmailer/files/digest-actionmailer-1.3.3 b/dev-ruby/actionmailer/files/digest-actionmailer-1.3.3
new file mode 100644 (file)
index 0000000..a5aab89
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 46896773f58dfbd49a4a8dcaf86b142d actionmailer-1.3.3.gem 84480
+RMD160 555ae7f370e72a26b899c9fe1edd7c74a36a289a actionmailer-1.3.3.gem 84480
+SHA256 f4f32778a4f8bac995ffcd0e70df807cd92d287b4e0f2659b111ea020a23d734 actionmailer-1.3.3.gem 84480
index 31a5474b3d3a32395abe2841268af483242d90b0..a3a6aa21f180af7cf43895b707630e2282cefb9e 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/actionpack
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.53 2007/03/04 20:28:04 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.54 2007/03/14 04:21:00 nichoj Exp $
+
+*actionpack-1.13.3 (14 Mar 2007)
+
+  14 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +actionpack-1.13.3.ebuild:
+  Version bump for rails 1.2.3.
 
   04 Mar 2007; Tom Gall <tgall@gentoo.org> actionpack-1.13.2.ebuild:
   added ~ppc64
diff --git a/dev-ruby/actionpack/actionpack-1.13.3.ebuild b/dev-ruby/actionpack/actionpack-1.13.3.ebuild
new file mode 100644 (file)
index 0000000..1b94993
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-1.13.3.ebuild,v 1.1 2007/03/14 04:21:00 nichoj Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="1.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5
+       =dev-ruby/activesupport-1.4.2"
diff --git a/dev-ruby/actionpack/files/digest-actionpack-1.13.3 b/dev-ruby/actionpack/files/digest-actionpack-1.13.3
new file mode 100644 (file)
index 0000000..cc4982d
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 14eb31b2c9fdf318004a7cbafc80d5f5 actionpack-1.13.3.gem 607232
+RMD160 f2038df4a70e6230f81e438662785edb3fae129a actionpack-1.13.3.gem 607232
+SHA256 7d1e15966496f95a3a211af908fd3cd45224ce6142e5b0b21e0c6e10a49ca359 actionpack-1.13.3.gem 607232
index 5a3b42d4f7c683a0607d6ecea69a616b1a18e8f7..b896360082c30bac09b5b7905fcc2d1d613a5814 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/actionwebservice
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionwebservice/ChangeLog,v 1.52 2007/03/04 20:50:02 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionwebservice/ChangeLog,v 1.53 2007/03/14 04:26:15 nichoj Exp $
+
+*actionwebservice-1.2.3 (14 Mar 2007)
+
+  14 Mar 2007; Joshua Nichols <nichoj@gentoo.org>
+  +actionwebservice-1.2.3.ebuild:
+  Version bump for rails 1.2.3.
 
   04 Mar 2007; Tom Gall <tgall@gentoo.org> actionwebservice-1.2.2.ebuild:
   added ~ppc64
diff --git a/dev-ruby/actionwebservice/actionwebservice-1.2.3.ebuild b/dev-ruby/actionwebservice/actionwebservice-1.2.3.ebuild
new file mode 100644 (file)
index 0000000..6bb1af3
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionwebservice/actionwebservice-1.2.3.ebuild,v 1.1 2007/03/14 04:26:15 nichoj Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="Simple Support for Web Services APIs for Rails"
+HOMEPAGE="http://rubyforge.org/projects/aws/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="1.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5
+       =dev-ruby/actionpack-1.13.3
+       =dev-ruby/activerecord-1.15.3
+       =dev-ruby/activesupport-1.4.2"
diff --git a/dev-ruby/actionwebservice/files/digest-actionwebservice-1.2.3 b/dev-ruby/actionwebservice/files/digest-actionwebservice-1.2.3
new file mode 100644 (file)
index 0000000..51e2753
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 59604dcdf9c6d32d7cff9146f51eae13 actionwebservice-1.2.3.gem 67584
+RMD160 501d4fd37b2ec1666946a0f29cbf63900b4c04a2 actionwebservice-1.2.3.gem 67584
+SHA256 1cf6ac60c59e7eb7286af881c48a0243e1318fefe4178d0742b8c480852aeaad actionwebservice-1.2.3.gem 67584
index 48b7c2af7ddac7ee0671ce3b48b82973951030b3..1c7e9b952429a583814a04ef273de8cac9c65f97 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/activerecord
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.50 2007/03/04 20:40:41 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.51 2007/03/14 04:24:14 nichoj Exp $
+
+*activerecord-1.15.3 (14 Mar 2007)
+
+  14 Mar 2007; Joshua Nichols <nichoj@gentoo.org>
+  +activerecord-1.15.3.ebuild:
+  Version bump for rails 1.2.3.
 
   04 Mar 2007; Tom Gall <tgall@gentoo.org> activerecord-1.15.2.ebuild:
   added ~ppc64
diff --git a/dev-ruby/activerecord/activerecord-1.15.3.ebuild b/dev-ruby/activerecord/activerecord-1.15.3.ebuild
new file mode 100644 (file)
index 0000000..deb0df6
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-1.15.3.ebuild,v 1.1 2007/03/14 04:24:14 nichoj Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="1.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+       =dev-ruby/activesupport-1.4.2"
diff --git a/dev-ruby/activerecord/files/digest-activerecord-1.15.3 b/dev-ruby/activerecord/files/digest-activerecord-1.15.3
new file mode 100644 (file)
index 0000000..2e12c44
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 fd461e595441731e34c8235a94bd0372 activerecord-1.15.3.gem 406016
+RMD160 573c8c9ce5557ad478ef0bd9e8ffeffb7e594f5f activerecord-1.15.3.gem 406016
+SHA256 fade9b34b98d4b583382299204dad2a87fe9895195e3439320cb27320e8dc4a6 activerecord-1.15.3.gem 406016
index af5e2964a2c1a94108df46478663b79158137e71..4a2fd2e399980c6fe32737a48a32fc9be0099cda 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/activesupport
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.40 2007/03/04 20:26:00 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.41 2007/03/14 04:20:08 nichoj Exp $
+
+*activesupport-1.4.2 (14 Mar 2007)
+
+  14 Mar 2007; Joshua Nichols <nichoj@gentoo.org>
+  +activesupport-1.4.2.ebuild:
+  Version bump for rails 1.2.3.
 
   04 Mar 2007; Tom Gall <tgall@gentoo.org>
   activesupport-1.4.1.ebuild:
diff --git a/dev-ruby/activesupport/activesupport-1.4.2.ebuild b/dev-ruby/activesupport/activesupport-1.4.2.ebuild
new file mode 100644 (file)
index 0000000..99de389
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-1.4.2.ebuild,v 1.1 2007/03/14 04:20:08 nichoj Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="1.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5
+       >=dev-ruby/rubygems-0.9.0"
diff --git a/dev-ruby/activesupport/files/digest-activesupport-1.4.2 b/dev-ruby/activesupport/files/digest-activesupport-1.4.2
new file mode 100644 (file)
index 0000000..2a37da5
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 b52b89c56bc653849f8a9a9027bbaad9 activesupport-1.4.2.gem 217088
+RMD160 70fefa6ec77f49142eaf2c0f255833b0b18938be activesupport-1.4.2.gem 217088
+SHA256 cc0e51ee3f8a52ebc96928b5072302f7897d40e5c9c7d18679cb7fe35a5ceb03 activesupport-1.4.2.gem 217088
index 5f36e93da4ad273839af7d98a455990e66fce7ec..3c8e979232ba0af1fa7ba58b034e720773454fa9 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-ruby/rails
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.71 2007/02/11 20:20:45 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.72 2007/03/14 04:27:24 nichoj Exp $
+
+*rails-1.2.3 (14 Mar 2007)
+
+  14 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.3.ebuild:
+  Version bump for rails 1.2.3.
 
 *rails-1.2.2 (11 Feb 2007)
 
diff --git a/dev-ruby/rails/files/digest-rails-1.2.3 b/dev-ruby/rails/files/digest-rails-1.2.3
new file mode 100644 (file)
index 0000000..461eb4b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 73ddfb89852c4b4ee749a3842d9d8f91 rails-1.2.3.gem 168448
+RMD160 4a2e95cdbee45b331205a7f5c1f1c278cc6ffdd0 rails-1.2.3.gem 168448
+SHA256 dcf51cc3bbf8ba79e998239d2bce66059d2be101210580e194b7af36b7d5319a rails-1.2.3.gem 168448
diff --git a/dev-ruby/rails/rails-1.2.3.ebuild b/dev-ruby/rails/rails-1.2.3.ebuild
new file mode 100644 (file)
index 0000000..4e988cb
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-1.2.3.ebuild,v 1.1 2007/03/14 04:27:24 nichoj Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+SRC_URI="http://gems.rubyonrails.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="1.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="mysql sqlite sqlite3 postgres fastcgi"
+DEPEND=">=dev-lang/ruby-1.8.5
+       >=dev-ruby/rake-0.7.1
+       =dev-ruby/activerecord-1.15.3
+       =dev-ruby/actionmailer-1.3.3
+       =dev-ruby/actionwebservice-1.2.3
+       =dev-ruby/activesupport-1.4.2
+       =dev-ruby/actionpack-1.13.3"
+
+RDEPEND="${DEPEND}
+       fastcgi? ( >=dev-ruby/ruby-fcgi-0.8.6 )
+       sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+       sqlite3? ( dev-ruby/sqlite3-ruby )
+       mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+       postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"