dev-python/pygtk: Unconditionally --disable-numpy
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 28 Jan 2020 19:47:01 +0000 (20:47 +0100)
committerMart Raudsepp <leio@gentoo.org>
Sun, 15 Mar 2020 19:37:14 +0000 (21:37 +0200)
Reported-by: Perfect Gentleman <perfect007gentleman@gmail.com>
Bug: https://bugs.gentoo.org/662518
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/14540
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-python/pygtk/pygtk-2.24.0-r5.ebuild

index f86cab545d536bdf5978c297a23b5b55a7be58ff..7678728182983860c1c58f0f20f094d7c9dfdab8 100644 (file)
@@ -25,10 +25,6 @@ RDEPEND="${PYTHON_DEPS}
        >=x11-libs/gtk+-2.24:2
        >=dev-python/pycairo-1.0.2[${PYTHON_USEDEP}]
        >=dev-python/pygobject-2.26.8-r53:2[${PYTHON_USEDEP}]
-       || (
-               >=dev-python/numpy-python2-1.16.5[${PYTHON_USEDEP}]
-               <dev-python/numpy-1.17.4[${PYTHON_USEDEP}]
-       )
        >=gnome-base/libglade-2.5:2.0
 "
 DEPEND="${RDEPEND}
@@ -77,6 +73,7 @@ src_configure() {
        configure_pygtk() {
                ECONF_SOURCE="${S}" gnome2_src_configure \
                        $(use_enable doc docs) \
+                       --disable-numpy \
                        --with-glade \
                        --enable-thread
        }