dev-python/sybil: Enable tests, set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Sun, 8 Mar 2020 13:34:08 +0000 (14:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 8 Mar 2020 14:26:00 +0000 (15:26 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sybil/sybil-1.2.0-r1.ebuild [moved from dev-python/sybil/sybil-1.2.0.ebuild with 71% similarity]

similarity index 71%
rename from dev-python/sybil/sybil-1.2.0.ebuild
rename to dev-python/sybil/sybil-1.2.0-r1.ebuild
index 07699278de28ceaa554866a917ddacadc421a6d3..3918a42c35cdbd3302d915d99f44d02b1005398e 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python3_{6,7,8} )
 inherit distutils-r1
 
@@ -14,6 +15,8 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 
-RDEPEND="${DEPEND}"
+# nose is used to test nosetests integration
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]"
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest