dev-libs/libidmef: EAPI=7 update
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Mon, 6 May 2019 18:32:29 +0000 (20:32 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 8 May 2019 22:56:12 +0000 (00:56 +0200)
Closes: https://bugs.gentoo.org/685218
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/11921
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/libidmef/libidmef-1.0.3-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/libidmef/libidmef-1.0.3-r1.ebuild b/dev-libs/libidmef/libidmef-1.0.3-r1.ebuild
new file mode 100644 (file)
index 0000000..e7cba52
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementation of the IDMEF XML draft"
+HOMEPAGE="https://sourceforge.net/projects/libidmef/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND=">=dev-libs/libxml2-2.5.10"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+       econf \
+               $(use_enable debug) \
+               $(use_enable static-libs static)
+}