Missing return value checks. Fix for bug #136167.
authorCarsten Lohrke <carlo@gentoo.org>
Thu, 15 Jun 2006 00:07:46 +0000 (00:07 +0000)
committerCarsten Lohrke <carlo@gentoo.org>
Thu, 15 Jun 2006 00:07:46 +0000 (00:07 +0000)
Package-Manager: portage-2.1

kde-base/kdenetwork/ChangeLog
kde-base/kdenetwork/files/digest-kdenetwork-3.5.3-r1 [new file with mode: 0644]
kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild [new file with mode: 0644]

index 3cfb97dd621f4384735c509e928454cf06c80043..dc0988fe960b5bab6df87aa496474a16d6a51685 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for kde-base/kdenetwork
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.206 2006/06/03 11:01:19 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.207 2006/06/15 00:07:45 carlo Exp $
+
+*kdenetwork-3.5.3-r1 (15 Jun 2006)
+
+  15 Jun 2006; Carsten Lohrke <carlo@gentoo.org>
+  +kdenetwork-3.5.3-r1.ebuild:
+  Missing return value checks. Fix for bug #136167.
 
   03 Jun 2006; Guy Martin <gmsoft@gentoo.org> kdenetwork-3.5.2.ebuild:
   Stable on hppa.
diff --git a/kde-base/kdenetwork/files/digest-kdenetwork-3.5.3-r1 b/kde-base/kdenetwork/files/digest-kdenetwork-3.5.3-r1
new file mode 100644 (file)
index 0000000..0d9cb09
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 119af91a048c34d9a917a1898f215554 kdenetwork-3.5.3.tar.bz2 7524718
+RMD160 0c57f39652946c577ad0d6ec7f4fc593fe38a0bc kdenetwork-3.5.3.tar.bz2 7524718
+SHA256 f0323e33226b30ca30bfee05a9b6da8a1de964c9593d134294f83a54db0f4f3c kdenetwork-3.5.3.tar.bz2 7524718
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild
new file mode 100644 (file)
index 0000000..fc7d5ac
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.3-r1.ebuild,v 1.1 2006/06/15 00:07:46 carlo Exp $
+
+inherit kde-dist eutils flag-o-matic
+
+DESCRIPTION="KDE network applications: Kopete, KPPP, KGet,..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="rdesktop sametime slp ssl wifi xmms"
+
+SRC_URI="${SRC_URI}
+       mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+BOTH_DEPEND="~kde-base/kdebase-${PV}
+       dev-libs/libxslt
+       dev-libs/libxml2
+       net-dns/libidn
+       >=dev-libs/glib-2
+       app-crypt/qca
+       sametime? ( =net-libs/meanwhile-0.4* )
+       xmms? ( media-sound/xmms )
+       slp? ( net-libs/openslp )
+       wifi? ( net-wireless/wireless-tools )
+       || ( (
+               x11-libs/libX11
+               x11-libs/libXext
+               x11-libs/libXrender
+               x11-libs/libXScrnSaver
+               ) virtual/x11 )
+       kernel_linux? ( virtual/opengl )"
+
+RDEPEND="${BOTH_DEPEND}
+       rdesktop? ( >=net-misc/rdesktop-1.4.1 )
+       dev-lang/perl
+       ssl? ( dev-perl/IO-Socket-SSL
+               app-crypt/qca-tls )"
+
+DEPEND="${BOTH_DEPEND}
+       kernel_linux? ( virtual/os-headers )
+       || ( (
+                       x11-proto/videoproto
+                       x11-proto/xextproto
+                       x11-proto/xproto
+                       kernel_linux? ( x11-libs/libXv )
+                       x11-proto/scrnsaverproto
+               ) virtual/x11 )
+       dev-util/pkgconfig"
+
+src_compile() {
+       export BINDNOW_FLAGS="$(bindnow-flags)"
+
+       local myconf="--with-libidn
+                     $(use_enable sametime sametime-plugin)
+                     $(use_enable slp) $(use_with wifi)
+                     $(use_with xmms) --without-external-libgadu"
+
+       kde_src_compile
+}
+
+src_install() {
+       kde_src_install
+
+       chmod u+s ${D}/${KDEDIR}/bin/reslisa
+
+       # empty config file needed for lisa to work with default settings
+       dodir /etc
+       touch ${D}/etc/lisarc
+
+       # lisa, reslisa initscripts
+       sed -e "s:_KDEDIR_:${KDEDIR}:g" ${WORKDIR}/patches/lisa > ${T}/lisa
+       sed -e "s:_KDEDIR_:${KDEDIR}:g" ${WORKDIR}/patches/reslisa > ${T}/reslisa
+       exeinto /etc/init.d
+       doexe ${T}/lisa ${T}/reslisa
+
+       insinto /etc/conf.d
+       newins ${WORKDIR}/patches/lisa.conf lisa
+       newins ${WORKDIR}/patches/reslisa.conf reslisa
+}