fix build failures
authorWilliam Hubbs <williamh@gentoo.org>
Mon, 27 Apr 2020 03:16:18 +0000 (22:16 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 27 Apr 2020 03:17:49 +0000 (22:17 -0500)
Closes: https://bugs.gentoo.org/704070
Closes: https://bugs.gentoo.org/719716
Signed-off-by: William Hubbs <williamh@gentoo.org>
net-vpn/openvpn/openvpn-2.4.9.ebuild

index 684a4871fe8209bebf8cae090da1e31f0e828051..ab73cf1183cfd89fc375dfc9cfa99613d77ccb6e 100644 (file)
@@ -61,22 +61,34 @@ src_prepare() {
 }
 
 src_configure() {
+       local myeconfargs=(
+               $(use_enable inotify async-push)
+               $(use_enable ssl crypto)
+       )
+       if use ssl; then
+               myeconfargs+=(
+                       $(use_with ssl crypto-library $(usex mbedtls mbedtls openssl))
+               )
+               if use libressl || ! use mbedtls; then
+                       myeconfargs+=(
+                               $(use_enable pkcs11)
+                       )
+               fi
+       fi
+       myeconfargs+=(
+               $(use_enable lz4)
+               $(use_enable lzo)
+               $(use_enable plugins)
+               $(use_enable iproute2)
+               $(use_enable pam plugin-auth-pam)
+               $(use_enable down-root plugin-down-root)
+               $(use_enable systemd)
+       )
        SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
        TMPFILES_DIR="/usr/lib/tmpfiles.d" \
        IFCONFIG=/bin/ifconfig \
        ROUTE=/bin/route \
-       econf \
-               $(use_enable inotify async-push) \
-               $(use_enable ssl crypto) \
-               $(use_with ssl crypto-library $(usex mbedtls mbedtls openssl)) \
-               $(use_enable lz4) \
-               $(use_enable lzo) \
-               $(use_enable pkcs11) \
-               $(use_enable plugins) \
-               $(use_enable iproute2) \
-               $(use_enable pam plugin-auth-pam) \
-               $(use_enable down-root plugin-down-root) \
-               $(use_enable systemd)
+       econf "${myeconfargs[@]}"
 }
 
 src_test() {