media-libs/libdv: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:22 +0000 (18:31 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 17:31:22 +0000 (18:31 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/libdv/files/libdv-0.99-2.6.patch
media-libs/libdv/files/libdv-1.0.0-darwin.patch
media-libs/libdv/files/libdv-1.0.0-solaris.patch
media-libs/libdv/libdv-1.0.0-r4.ebuild

index c2663be353d4c3b1cd2660ec33626d6864122946..f9a5fb1e5fea89544be8dc4e5832fc90ade11566 100644 (file)
@@ -1,8 +1,8 @@
---- libdv-0.99/libdv/enc_input.c       2002-12-31 23:04:02.000000000 +0000
-+++ libdv-0.99/libdv/enc_input.c.plasmaroo     2003-12-30 16:42:19.000000000 +0000
-@@ -48,13 +48,13 @@
- #if HAVE_DEV_VIDEO
+--- a/libdv/enc_input.c
++++ b/libdv/enc_input.c
+@@ -50,13 +50,13 @@
+ #define _DEVICE_H_
+ #define _LINUX_TIME_H
  #include <sys/types.h>
 -#include <linux/videodev.h>
  #include <sys/time.h>
index c6d48d5a69492e7448b6312e0d04f3236be69eb7..5522e9d7e602f2ea03753b06bea9937d5e01a597 100644 (file)
@@ -2,8 +2,8 @@
 
 https://sourceforge.net/tracker/index.php?func=detail&aid=2606558&group_id=4393&atid=304393
 
---- configure.ac
-+++ configure.ac
+--- a/configure.ac
++++ b/configure.ac
 @@ -244,7 +244,7 @@
  
  dnl Checks for library functions.
@@ -13,8 +13,8 @@ https://sourceforge.net/tracker/index.php?func=detail&aid=2606558&group_id=4393&
  
  AC_SUBST(ac_aux_dir)
  AC_SUBST(RPM_RELEASE)
---- configure
-+++ configure
+--- a/configure
++++ b/configure
 @@ -22621,7 +22621,7 @@
  rm -f conftest.mmap
  
@@ -24,8 +24,8 @@ https://sourceforge.net/tracker/index.php?func=detail&aid=2606558&group_id=4393&
  do
  as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
  { echo "$as_me:$LINENO: checking for $ac_func" >&5
---- config.h.in
-+++ config.h.in
+--- a/config.h.in
++++ b/config.h.in
 @@ -24,6 +24,12 @@
  /* Define to 1 if you have the `gettimeofday' function. */
  #undef HAVE_GETTIMEOFDAY
@@ -39,8 +39,8 @@ https://sourceforge.net/tracker/index.php?func=detail&aid=2606558&group_id=4393&
  /* Define as 1 if you have gtk */
  #undef HAVE_GTK
  
---- encodedv/dvconnect.c
-+++ encodedv/dvconnect.c
+--- a/encodedv/dvconnect.c
++++ b/encodedv/dvconnect.c
 @@ -860,7 +860,7 @@
  
  int rt_raisepri (int pri)
index e9cb440022af36d17bb232fa176659f20b8dd9be..8580d4ba7fd619a3e35147b95e94a8136dec7df3 100644 (file)
@@ -3,8 +3,8 @@
 
 https://sourceforge.net/tracker/index.php?func=detail&aid=2603455&group_id=4393&atid=304393
 
---- configure.ac
-+++ configure.ac
+--- a/configure.ac
++++ b/configure.ac
 @@ -208,6 +208,8 @@
  
  
@@ -23,8 +23,8 @@ https://sourceforge.net/tracker/index.php?func=detail&aid=2603455&group_id=4393&
  
  dnl Checks for typedefs, structures, and compiler characteristics.
  AC_C_CONST
---- configure
-+++ configure
+--- a/configure
++++ b/configure
 @@ -20895,6 +20895,92 @@
  
  fi
@@ -127,8 +127,8 @@ https://sourceforge.net/tracker/index.php?func=detail&aid=2603455&group_id=4393&
  do
  as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
  if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
---- config.h.in
-+++ config.h.in
+--- a/config.h.in
++++ b/config.h.in
 @@ -30,6 +30,9 @@
  /* Define to 1 if you have the <inttypes.h> header file. */
  #undef HAVE_INTTYPES_H
@@ -139,8 +139,8 @@ https://sourceforge.net/tracker/index.php?func=detail&aid=2603455&group_id=4393&
  /* Define to 1 if you have the `m' library (-lm). */
  #undef HAVE_LIBM
  
---- encodedv/dvconnect.c
-+++ encodedv/dvconnect.c
+--- a/encodedv/dvconnect.c
++++ b/encodedv/dvconnect.c
 @@ -31,6 +31,9 @@
  
  #include <stdio.h>
index 6788633e8d693fdf9818ebd148c03dfab9f76b3c..cb80482cdaf1cf2f0889349e0958525b9523fab3 100644 (file)
@@ -1,44 +1,45 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit epatch epunt-cxx libtool ltprune flag-o-matic multilib-minimal
+inherit autotools flag-o-matic multilib-minimal
 
 DESCRIPTION="Software codec for dv-format video (camcorders etc)"
 HOMEPAGE="http://libdv.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+SRC_URI="
+       mirror://sourceforge/${PN}/${P}.tar.gz
        mirror://gentoo/${PN}-1.0.0-pic.patch.bz2"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="static-libs"
 
-RDEPEND="dev-libs/popt"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
+RDEPEND="dev-libs/popt:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
 
-DOCS=( AUTHORS ChangeLog INSTALL NEWS TODO )
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.99-2.6.patch
+       "${WORKDIR}"/${PN}-1.0.0-pic.patch
+       "${FILESDIR}"/${PN}-1.0.0-solaris.patch
+       "${FILESDIR}"/${PN}-1.0.0-darwin.patch
+)
 
 src_prepare() {
-       epatch "${FILESDIR}"/${PN}-0.99-2.6.patch
-       epatch "${WORKDIR}"/${PN}-1.0.0-pic.patch
-       epatch "${FILESDIR}"/${PN}-1.0.0-solaris.patch
-       epatch "${FILESDIR}"/${PN}-1.0.0-darwin.patch
-       elibtoolize
-       epunt_cxx #74497
+       default
+       eautoreconf
 
        append-cppflags "-I${S}"
 }
 
 multilib_src_configure() {
        ECONF_SOURCE="${S}"     econf \
-               $(use_enable static-libs static) \
+               --disable-static \
                --without-debug \
                --disable-gtk \
-               --disable-gtktest \
                $([[ ${CHOST} == *86*-darwin* ]] && echo "--disable-asm")
+
        if ! multilib_is_native_abi ; then
                sed -i \
                        -e 's/ encodedv//' \
@@ -47,6 +48,8 @@ multilib_src_configure() {
 }
 
 multilib_src_install_all() {
-       prune_libtool_files --all
        einstalldocs
+
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }