dev-java/leiningen-bin: Fix prefix support and add ~x64-macos
authorYegor Timoshenko <yegortimoshenko@gmail.com>
Tue, 9 May 2017 03:57:05 +0000 (15:57 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 10 May 2017 11:45:40 +0000 (23:45 +1200)
~x64-macos tested by Yegor Timoshenko

Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-java/leiningen-bin/leiningen-bin-2.7.1.ebuild

index 807741b31949e5674ce99e7977864b0d3f04fa17..a6a5f01087f091433813c623f96abcab70a90c8b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -17,7 +17,7 @@ SRC_URI="
 
 LICENSE="EPL-1.0"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
 
 RDEPEND=">=virtual/jdk-1.6:*"
 DEPEND=">=virtual/jdk-1.6:*"
@@ -45,7 +45,7 @@ src_prepare() {
 
        einfo "Patching lein"
        java-pkg_init_paths_
-       sed -i "s|^LEIN_JAR=.*$|LEIN_JAR=${JAVA_PKG_JARDEST}/${PN}.jar|" "${S}/lein" \
+       sed -i "s|^LEIN_JAR=.*$|LEIN_JAR=${EPREFIX}/${JAVA_PKG_JARDEST#/}/${PN}.jar|" "${S}/lein" \
                || die "Can't patch LEIN_JAR in lein"
 
        default