old
authorMike Frysinger <vapier@gentoo.org>
Sun, 31 Dec 2006 11:17:28 +0000 (11:17 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sun, 31 Dec 2006 11:17:28 +0000 (11:17 +0000)
app-arch/gzip/files/digest-gzip-1.3.5-r8 [deleted file]
app-arch/gzip/files/digest-gzip-1.3.5-r9 [deleted file]
app-arch/gzip/gzip-1.3.5-r8.ebuild [deleted file]
app-arch/gzip/gzip-1.3.5-r9.ebuild [deleted file]

diff --git a/app-arch/gzip/files/digest-gzip-1.3.5-r8 b/app-arch/gzip/files/digest-gzip-1.3.5-r8
deleted file mode 100644 (file)
index cc0c9a5..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3d6c191dfd2bf307014b421c12dc8469 gzip-1.3.5.tar.gz 331550
-RMD160 5011f20441f31838c34b981c325107dd85737ff9 gzip-1.3.5.tar.gz 331550
-SHA256 631820e566353eafc4bdc0d9d8221c26c7ef6b5d10a254783dbe9bcac88caa07 gzip-1.3.5.tar.gz 331550
diff --git a/app-arch/gzip/files/digest-gzip-1.3.5-r9 b/app-arch/gzip/files/digest-gzip-1.3.5-r9
deleted file mode 100644 (file)
index cc0c9a5..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3d6c191dfd2bf307014b421c12dc8469 gzip-1.3.5.tar.gz 331550
-RMD160 5011f20441f31838c34b981c325107dd85737ff9 gzip-1.3.5.tar.gz 331550
-SHA256 631820e566353eafc4bdc0d9d8221c26c7ef6b5d10a254783dbe9bcac88caa07 gzip-1.3.5.tar.gz 331550
diff --git a/app-arch/gzip/gzip-1.3.5-r8.ebuild b/app-arch/gzip/gzip-1.3.5-r8.ebuild
deleted file mode 100644 (file)
index e045241..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r8.ebuild,v 1.2 2006/03/30 15:15:00 flameeyes Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls build static pic"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-       nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-debian.patch
-       epatch "${FILESDIR}"/${P}-znew-tempfile-2.patch
-       epatch "${FILESDIR}"/${P}-gunzip-dir.patch
-       epatch "${FILESDIR}"/${P}-asm-execstack.patch
-       epatch "${FILESDIR}"/${P}-gzip-perm.patch
-       epatch "${FILESDIR}"/${P}-infodir.patch
-       epatch "${FILESDIR}"/${P}-rsync.patch
-       epatch "${FILESDIR}"/${P}-zgrep-sed.patch
-       epatch "${FILESDIR}"/${P}-alpha.patch
-       epatch "${FILESDIR}"/${P}-huft-build-return-fix.patch
-       epatch "${FILESDIR}"/${P}-zgreppipe.patch
-}
-
-src_compile() {
-       use static && append-flags -static
-       # avoid text relocation in gzip
-       use pic && export DEFS="NO_ASM"
-       econf --exec-prefix=/ $(use_enable nls) || die
-       emake || die
-}
-
-src_install() {
-       dodir /usr/bin /usr/share/man/man1
-       make prefix=${D}/usr \
-               exec_prefix=${D}/ \
-               mandir=${D}/usr/share/man \
-               infodir=${D}/usr/share/info \
-               install || die
-
-       cd ${D}/bin
-
-       for i in gzexe zforce zgrep zmore znew zcmp
-       do
-               sed -i -e "s:${D}::" ${i} || die
-               chmod 755 ${i}
-       done
-
-       # No need to waste space -- these guys should be links
-       # gzcat is equivilant to zcat, but historically zcat
-       # was a link to compress.
-       rm -f gunzip zcat zcmp zegrep zfgrep
-       dosym gzip /bin/gunzip
-       dosym gzip /bin/gzcat
-       dosym gzip /bin/zcat
-       dosym zdiff /bin/zcmp
-       dosym zgrep /bin/zegrep
-       dosym zgrep /bin/zfgrep
-
-       if ! use build
-       then
-               cd ${D}/usr/share/man/man1
-               rm -f gunzip.* zcmp.* zcat.*
-               ln -s gzip.1.gz gunzip.1.gz
-               ln -s zdiff.1.gz zcmp.1.gz
-               ln -s gzip.1.gz zcat.1.gz
-               ln -s gzip.1.gz gzcat.1.gz
-               cd ${S}
-               rm -rf ${D}/usr/man ${D}/usr/lib
-               dodoc ChangeLog NEWS README THANKS TODO
-               docinto txt
-               dodoc algorithm.doc gzip.doc
-       else
-               rm -rf ${D}/usr
-       fi
-}
diff --git a/app-arch/gzip/gzip-1.3.5-r9.ebuild b/app-arch/gzip/gzip-1.3.5-r9.ebuild
deleted file mode 100644 (file)
index 7fa1a3d..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip/gzip-1.3.5-r9.ebuild,v 1.11 2006/11/11 09:36:40 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Standard GNU compressor"
-HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls build static pic"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-       nls? ( sys-devel/gettext )"
-PROVIDE="virtual/gzip"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-CVE-2006-4334-8.patch
-       epatch "${FILESDIR}"/${P}-debian.patch
-       epatch "${FILESDIR}"/${P}-znew-tempfile-2.patch
-       epatch "${FILESDIR}"/${P}-gunzip-dir.patch
-       epatch "${FILESDIR}"/${P}-asm-execstack.patch
-       epatch "${FILESDIR}"/${P}-gzip-perm.patch
-       epatch "${FILESDIR}"/${P}-infodir.patch
-       epatch "${FILESDIR}"/${P}-rsync.patch
-       epatch "${FILESDIR}"/${P}-zgrep-sed.patch
-       epatch "${FILESDIR}"/${P}-alpha.patch
-       epatch "${FILESDIR}"/${P}-zgreppipe.patch
-}
-
-src_compile() {
-       use static && append-flags -static
-       # avoid text relocation in gzip
-       use pic && export DEFS="NO_ASM"
-       econf --exec-prefix=/ $(use_enable nls) || die
-       emake || die
-}
-
-src_install() {
-       dodir /usr/bin /usr/share/man/man1
-       make prefix=${D}/usr \
-               exec_prefix=${D}/ \
-               mandir=${D}/usr/share/man \
-               infodir=${D}/usr/share/info \
-               install || die
-
-       cd ${D}/bin
-
-       for i in gzexe zforce zgrep zmore znew zcmp
-       do
-               sed -i -e "s:${D}::" ${i} || die
-               chmod 755 ${i}
-       done
-
-       # No need to waste space -- these guys should be links
-       # gzcat is equivilant to zcat, but historically zcat
-       # was a link to compress.
-       rm -f gunzip zcat zcmp zegrep zfgrep
-       dosym gzip /bin/gunzip
-       dosym gzip /bin/gzcat
-       dosym gzip /bin/zcat
-       dosym zdiff /bin/zcmp
-       dosym zgrep /bin/zegrep
-       dosym zgrep /bin/zfgrep
-
-       if ! use build
-       then
-               cd ${D}/usr/share/man/man1
-               rm -f gunzip.* zcmp.* zcat.*
-               ln -s gzip.1.gz gunzip.1.gz
-               ln -s zdiff.1.gz zcmp.1.gz
-               ln -s gzip.1.gz zcat.1.gz
-               ln -s gzip.1.gz gzcat.1.gz
-               cd ${S}
-               rm -rf ${D}/usr/man ${D}/usr/lib
-               dodoc ChangeLog NEWS README THANKS TODO
-               docinto txt
-               dodoc algorithm.doc gzip.doc
-       else
-               rm -rf ${D}/usr
-       fi
-}