kde-frameworks/oxygen-icons: Add missing !test handling
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 11 Nov 2019 07:25:13 +0000 (08:25 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 11 Nov 2019 07:34:08 +0000 (08:34 +0100)
We don't inherit ecm.eclass so we need to do a bit extra.

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-frameworks/oxygen-icons/oxygen-icons-5.64.0.ebuild

index f6a1cd6cecbab39783a54090b830c5ec4dba926f..e821e17f2db4319d48086720decd4127f2e4df66 100644 (file)
@@ -21,3 +21,8 @@ BDEPEND="
 DEPEND="test? ( dev-qt/qttest:5 )"
 
 RESTRICT+=" !test? ( test )"
+
+src_prepare() {
+       cmake-utils_src_prepare
+       use test || cmake_comment_add_subdirectory autotests
+}