die if iproute2 support was requested, but built with the minimal USE flag.
authorRoy Marples <uberlord@gentoo.org>
Mon, 6 Nov 2006 09:52:22 +0000 (09:52 +0000)
committerRoy Marples <uberlord@gentoo.org>
Mon, 6 Nov 2006 09:52:22 +0000 (09:52 +0000)
Fixes #154191 thanks to Martin Scherer.
Package-Manager: portage-2.1.2_rc1-r2

net-misc/openvpn/ChangeLog
net-misc/openvpn/openvpn-2.0.6.ebuild
net-misc/openvpn/openvpn-2.0.7.ebuild
net-misc/openvpn/openvpn-2.1_rc1.ebuild

index aa99c9d5b01b32ea645ade334cf3dd7fdf7385d3..070dc94082aba8e2d5471f1d061b42d47e1207ba 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-misc/openvpn
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.100 2006/11/02 11:09:07 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.101 2006/11/06 09:52:22 uberlord Exp $
+
+  06 Nov 2006; Roy Marples <uberlord@gentoo.org> openvpn-2.0.6.ebuild,
+  openvpn-2.0.7.ebuild, -openvpn-2.1_beta15.ebuild, openvpn-2.1_rc1.ebuild:
+  die if iproute2 support was requested, but built with the minimal USE flag.
+  Fixes #154191 thanks to Martin Scherer.
 
 *openvpn-2.1_rc1 (02 Nov 2006)
 
index cb6eaf7f0884ab94fa0240b3e76f28ff9fb57bfb..ad4a046639db16adadec3f18a76b9ee98fe28217 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.6.ebuild,v 1.11 2006/07/08 08:22:06 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.6.ebuild,v 1.12 2006/11/06 09:52:22 uberlord Exp $
 
 inherit eutils gnuconfig multilib
 
@@ -23,6 +23,16 @@ RDEPEND=">=dev-libs/lzo-1.07
 DEPEND="${RDEPEND}
        virtual/os-headers"
 
+pkg_setup() {
+       if use iproute2 ; then
+               if built_with_use sys-apps/iproute2 minimal ; then
+                       eerror "iproute2 support requires that sys-apps/iproute2 was not"
+                       eerror "built with the minimal USE flag"
+                       die "iproute2 support not available"
+               fi
+       fi
+}
+
 src_unpack() {
        unpack "${A}"
        gnuconfig_update
index 0138b23302f8b0ce56ff88458b77f52f0c80abb1..a372f34dd543def07562a10b79ac91641c227150 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.7.ebuild,v 1.3 2006/10/17 14:55:03 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.7.ebuild,v 1.4 2006/11/06 09:52:22 uberlord Exp $
 
 inherit eutils gnuconfig multilib
 
@@ -23,6 +23,16 @@ RDEPEND=">=dev-libs/lzo-1.07
 DEPEND="${RDEPEND}
        virtual/os-headers"
 
+pkg_setup() {
+       if use iproute2 ; then
+               if built_with_use sys-apps/iproute2 minimal ; then
+                       eerror "iproute2 support requires that sys-apps/iproute2 was not"
+                       eerror "built with the minimal USE flag"
+                       die "iproute2 support not available"
+               fi
+       fi
+}
+
 src_unpack() {
        unpack "${A}"
        cd "${S}"
index aeac948bff997cdc2e8601fe211ab5c044322895..40a1facc3a950120ceb0e7eb47cac8e659d168e7 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.1_rc1.ebuild,v 1.1 2006/11/02 11:09:07 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.1_rc1.ebuild,v 1.2 2006/11/06 09:52:22 uberlord Exp $
 
 inherit eutils gnuconfig multilib
 
@@ -21,6 +21,16 @@ DEPEND=">=dev-libs/lzo-1.07
        selinux? ( sec-policy/selinux-openvpn )
        ssl? ( >=dev-libs/openssl-0.9.6 )"
 
+pkg_setup() {
+       if use iproute2 ; then
+               if built_with_use sys-apps/iproute2 minimal ; then
+                       eerror "iproute2 support requires that sys-apps/iproute2 was not"
+                       eerror "built with the minimal USE flag"
+                       die "iproute2 support not available"
+               fi
+       fi
+}
+
 src_unpack() {
        unpack ${A}
        cd "${S}"
@@ -141,4 +151,11 @@ pkg_postinst() {
                einfo ""
                einfo "plugins have been installed into /usr/$(get_libdir)/${PN}"
        fi
+
+       if use userland_BSD ; then
+               ewarn ""
+               ewarn "If you run any kind of firewall on BSD and use IPv6 acrosss"
+               ewarn "OpenVPN then you'll probably have to lower the MTU to 1420"
+               ewarn "using the tun-mtu statement (even for tap devices)"
+       fi
 }