app-admin/mcelog: bump to 169
authorBen Kohler <bkohler@gentoo.org>
Fri, 24 Apr 2020 12:53:48 +0000 (07:53 -0500)
committerBen Kohler <bkohler@gentoo.org>
Fri, 24 Apr 2020 12:54:17 +0000 (07:54 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
app-admin/mcelog/Manifest
app-admin/mcelog/mcelog-169.ebuild [new file with mode: 0644]

index 29d9dde7d14feba9f87d79a8a81e40aeb3c63fb1..9507a4566e945e16ef7fa83cd85481a6f270e142 100644 (file)
@@ -1 +1,2 @@
 DIST mcelog-168.tar.gz 312580 BLAKE2B 1a97869cc183c4263bf9868ccdc24b15658de0e863bd03ecdf61b0c6a03f5737dceec1b5237a8dfdf2f889cab9d55d3b5274bde5533841fc1aa56ed2189f5ffc SHA512 81f4ccb2632e5c34c52aea430a682e44d6b9850fbee2e9180a493025bbea660a7a4eaff3ee1e2f6e3d3700d3c951c09c4534b733cca5c809ad9c5a1ff8b07295
+DIST mcelog-169.tar.gz 312584 BLAKE2B 2c24f5db6178d3d3929fe18e8ee130ff827920bff4478cefc244893a68e7ec2e470cb39d1a044009f3c7ac280dbd41088f1716a3db17e23ca4979c554ae39d7a SHA512 df1bf5a3dd2cf4d8fa4fb454f4837841a832beff5c5521db404dbcee600ff7d492853e67323b00aeb3365d6734fa2ea879b13b942e8d431eaff15d31dfb1a1c8
diff --git a/app-admin/mcelog/mcelog-169.ebuild b/app-admin/mcelog/mcelog-169.ebuild
new file mode 100644 (file)
index 0000000..e0b67a2
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A tool to log and decode Machine Check Exceptions"
+HOMEPAGE="http://mcelog.org/"
+SRC_URI="https://github.com/andikleen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-mcelog )"
+
+# TODO: add mce-inject to the tree to support test phase
+RESTRICT="test"
+
+pkg_pretend() {
+       if [[ ${MERGE_TYPE} != buildonly ]]; then
+               local CONFIG_CHECK="~X86_MCE"
+               kernel_is -ge 4 12 && CONFIG_CHECK+=" ~X86_MCELOG_LEGACY"
+               check_extra_config
+       fi
+}
+
+src_prepare() {
+       eapply "${FILESDIR}"/${PN}-0.8_pre1-timestamp-${PN}.patch \
+               "${FILESDIR}"/${PN}-129-debugflags.patch
+       eapply_user
+       tc-export CC
+}
+
+src_install() {
+       default
+
+       insinto /etc/cron.daily
+       newins ${PN}.cron ${PN}
+
+       insinto /etc/logrotate.d/
+       newins ${PN}.logrotate ${PN}
+
+       newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
+       systemd_dounit "${FILESDIR}"/${PN}.service
+
+       dodoc *.pdf
+}
+
+pkg_postinst() {
+       einfo "The default configuration set is now installed in /etc/${PN}"
+       einfo "you might want to edit those files."
+       einfo
+       einfo "A sample cronjob is installed into /etc/cron.daily"
+       einfo "without executable bit (system service is the preferred method now)"
+}