app-emulation/buildah: Remove old versions
authorZac Medico <zmedico@gentoo.org>
Tue, 26 Nov 2019 03:29:27 +0000 (19:29 -0800)
committerZac Medico <zmedico@gentoo.org>
Tue, 26 Nov 2019 03:29:46 +0000 (19:29 -0800)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-emulation/buildah/Manifest
app-emulation/buildah/buildah-1.11.2.ebuild [deleted file]
app-emulation/buildah/buildah-1.11.3.ebuild [deleted file]
app-emulation/buildah/metadata.xml

index 7ca2df07441635a4383f133d160a5f885aab662d..4cbdecb560f65a7c6d6c2a13e3af87fcbc237b9f 100644 (file)
@@ -1,3 +1 @@
-DIST buildah-1.11.2.tar.gz 10128075 BLAKE2B ad8f4253b62cd7709bf5ae530d002190c1850da6bbfa7dff2281de0592422eccc67a4ba6e52f7a82d6c1b320b986237a84d0ffaaf9b3b1b93822a54621365250 SHA512 f491d96d5bb4d0aa03981fb58d24f36c2e3928179c8fb79e85f323ce9a65ae6da05b816d86ae43f94a83a1b2445b315f93ca28b531436d9b4e5861e4adef2aac
-DIST buildah-1.11.3.tar.gz 10429884 BLAKE2B 2d433a128d115c6b2f3a9d246d41406993905dee357237796cea3295036d026ca93f8c98ca992cfebfa574ab0d5e7b974fd356a146b7cde58986166bc18a5645 SHA512 07fff3f8c044ad01a663bf5470b19f75568ce741b3bb45f656200099ba559622597111ede3e20331dc06139f2e58d962d92bf0fdd00284ca6ed05b5b66500975
 DIST buildah-1.11.5.tar.gz 10594213 BLAKE2B 421d4ea78ad84fbae42086b8d49fec26db8e2aa1f83e261a8b5b1f3f41a5be4ea2fdeb41d4e27fb52bf23f309b8aea1d050cea0c6deffcad0ebb273032e712ba SHA512 04a9c51e1cb6f3a88f118b69dcea1eba85b02d534e671cd5bf31a6d6a797bce4a488c9373c92736fccd74331c1242ff60a95f44626ecbb50c32db176c7106e86
diff --git a/app-emulation/buildah/buildah-1.11.2.ebuild b/app-emulation/buildah/buildah-1.11.2.ebuild
deleted file mode 100644 (file)
index 6a58e5f..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 golang-vcs-snapshot
-
-KEYWORDS="~amd64"
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="ostree selinux"
-EGO_PN="${HOMEPAGE#*//}"
-EGIT_COMMIT="v${PV}"
-GIT_COMMIT="0bafbfe"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-RDEPEND="app-crypt/gpgme:=
-       app-emulation/skopeo
-       dev-libs/libgpg-error:=
-       dev-libs/libassuan:=
-       sys-fs/lvm2:=
-       sys-libs/libseccomp:=
-       selinux? ( sys-libs/libselinux:= )"
-DEPEND="${RDEPEND}"
-RESTRICT="test"
-REQUIRED_USE="!selinux? ( !ostree )"
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-src_prepare() {
-       default
-       sed -e 's|^\(GIT_COMMIT ?= \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
-
-       [[ -f ostree_tag.sh ]] || die
-       use ostree || { echo -e "#!/bin/sh\necho containers_image_ostree_stub" > \
-               ostree_tag.sh || die; }
-
-       [[ -f selinux_tag.sh ]] || die
-       use selinux || { echo -e "#!/bin/sh\ntrue" > \
-               selinux_tag.sh || die; }
-}
-
-src_compile() {
-       export -n GOCACHE XDG_CACHE_HOME
-       GOPATH="${WORKDIR}/${P}" emake all
-}
-
-src_install() {
-       dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
-       doman docs/*.1
-       dodoc -r docs/tutorials
-       dobin ${PN} imgtype
-       dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
-       GOPATH="${WORKDIR}/${P}" emake test-unit
-}
diff --git a/app-emulation/buildah/buildah-1.11.3.ebuild b/app-emulation/buildah/buildah-1.11.3.ebuild
deleted file mode 100644 (file)
index 42661d1..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 golang-vcs-snapshot
-
-KEYWORDS="~amd64"
-DESCRIPTION="A tool that facilitates building OCI images"
-HOMEPAGE="https://github.com/containers/buildah"
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="ostree selinux"
-EGO_PN="${HOMEPAGE#*//}"
-EGIT_COMMIT="v${PV}"
-GIT_COMMIT="bdd78ad"
-SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-RDEPEND="app-crypt/gpgme:=
-       app-emulation/skopeo
-       dev-libs/libgpg-error:=
-       dev-libs/libassuan:=
-       sys-fs/lvm2:=
-       sys-libs/libseccomp:=
-       selinux? ( sys-libs/libselinux:= )"
-DEPEND="${RDEPEND}"
-RESTRICT="test"
-REQUIRED_USE="!selinux? ( !ostree )"
-S="${WORKDIR}/${P}/src/${EGO_PN}"
-
-src_prepare() {
-       default
-       sed -e 's|^\(GIT_COMMIT ?= \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
-
-       [[ -f ostree_tag.sh ]] || die
-       use ostree || { echo -e "#!/bin/sh\necho containers_image_ostree_stub" > \
-               ostree_tag.sh || die; }
-
-       [[ -f selinux_tag.sh ]] || die
-       use selinux || { echo -e "#!/bin/sh\ntrue" > \
-               selinux_tag.sh || die; }
-}
-
-src_compile() {
-       export -n GOCACHE XDG_CACHE_HOME
-       GOPATH="${WORKDIR}/${P}" emake all
-}
-
-src_install() {
-       dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
-       doman docs/*.1
-       dodoc -r docs/tutorials
-       dobin ${PN} imgtype
-       dobashcomp contrib/completions/bash/buildah
-}
-
-src_test() {
-       GOPATH="${WORKDIR}/${P}" emake test-unit
-}
index aef68f1e5381649aa8574ce5132d454fe0663aeb..491730ac55c11f39bde3df30f96096c9ea3188e2 100644 (file)
@@ -5,11 +5,6 @@
                <email>zmedico@gentoo.org</email>
                <name>Zac Medico</name>
        </maintainer>
-       <use>
-               <flag name="ostree">
-                       Enables dependencies for handling of OSTree images.
-               </flag>
-       </use>
        <upstream>
                <remote-id type="github">containers/buildah</remote-id>
        </upstream>