sys-fs/btrfs-progs: Bump to version 5.1
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 18 May 2019 13:02:15 +0000 (15:02 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 18 May 2019 13:06:22 +0000 (15:06 +0200)
Bumped to EAPI-7

Closes: https://bugs.gentoo.org/686208
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-fs/btrfs-progs/Manifest
sys-fs/btrfs-progs/btrfs-progs-5.1.ebuild [new file with mode: 0644]

index ff190e8c0a6ab0f2b979382bc524b690116121c1..780995f63196745f6745ba6d2e02d69730101a26 100644 (file)
@@ -10,3 +10,4 @@ DIST btrfs-progs-v4.20.2.tar.xz 2028668 BLAKE2B 51ee331d39a2cb1f383cac311bbc4d51
 DIST btrfs-progs-v4.20.tar.xz 2028328 BLAKE2B f7038a6b454d44ce3899b6607fa5554150f5801a158e8296750acd1275d3ebffeb6284f2ff609a68b2df55b15479d3039ca94e1ecef0515bbc1b87281f536d2c SHA512 a8339f73079d74d61b8bc17cac57ae560746baa4104e496080bde5329b1bb70712f033cdd306f8c06db6b364f0087b424e7e33511cad5bfeed5c214518e16a27
 DIST btrfs-progs-v4.4.1.tar.xz 1173248 BLAKE2B 8bf07a3bc3d24a3f641c2dc7a6353f186ebd98f7a633bdbc2689359e6204b3f1db76accee3e648634f319e26b57e6376c13fa31d39413908d0b2308e0ae28d0e SHA512 3086e2e0385d9e14edcfa25e1aee1ed98087dd5b91a66aa450786c932d79841b5c4ee3f9a40b8fdecee0ba1e386196b89679d28e58e4924ce66cd78c5e3c0d4a
 DIST btrfs-progs-v4.9.1.tar.xz 1476524 BLAKE2B 3fdd1c040fdf8083fcf5d4106db22112aaba59dd9a6ab8ad164302ec153a83151fbf88d84181dc849c296bb96ad883d4f7329bff111c67c19fdb814db5073fb2 SHA512 143f5c8863f3b9eff2e4ca2c750bb80ffe62f66d0c15d23e6f5bf75dab0133dcd3ff4d4c722360560de24b73e3da1222f265230d18de06d7bccd85ad2cb9a6a5
+DIST btrfs-progs-v5.1.tar.xz 2042196 BLAKE2B 1a0ccc04dc55f66c639a64e4c6c4f8683376fa2e273217ea2fd544d7e3b666e95bbaaf35809e25bdc84e92b1430af698d8bb57ab2c5f8ce4899920e1e71b7c05 SHA512 45a42b2c64b8120eb4ce6fe9e37571e197bd142403223e96af758adb00c116086d6790c9ab7f9707b4784f7b67af18b50ccf990b0d8d79571e04b81b11859154
diff --git a/sys-fs/btrfs-progs/btrfs-progs-5.1.ebuild b/sys-fs/btrfs-progs/btrfs-progs-5.1.ebuild
new file mode 100644 (file)
index 0000000..4076d30
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit bash-completion-r1 python-single-r1
+
+libbtrfs_soname=0
+
+if [[ ${PV} != 9999 ]]; then
+       MY_PV="v${PV/_/-}"
+       [[ "${PV}" = *_rc* ]] || \
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+       SRC_URI="https://www.kernel.org/pub/linux/kernel/people/kdave/${PN}/${PN}-${MY_PV}.tar.xz"
+       S="${WORKDIR}/${PN}-${MY_PV}"
+else
+       WANT_LIBTOOL=none
+       inherit autotools git-r3
+       EGIT_REPO_URI="https://github.com/kdave/btrfs-progs.git"
+       EGIT_BRANCH="devel"
+fi
+
+DESCRIPTION="Btrfs filesystem utilities"
+HOMEPAGE="https://btrfs.wiki.kernel.org"
+
+LICENSE="GPL-2"
+SLOT="0/${libbtrfs_soname}"
+IUSE="+convert python reiserfs static static-libs +zstd"
+
+RESTRICT=test # tries to mount repared filesystems
+
+RDEPEND="
+       dev-libs/lzo:2=
+       sys-apps/util-linux:0=[static-libs(+)?]
+       sys-libs/zlib:0=
+       convert? (
+               sys-fs/e2fsprogs:0=
+               sys-libs/e2fsprogs-libs:0=
+               reiserfs? (
+                       >=sys-fs/reiserfsprogs-3.6.27
+               )
+       )
+       python? ( ${PYTHON_DEPS} )
+       zstd? ( app-arch/zstd:0= )
+"
+DEPEND="${RDEPEND}
+       convert? ( sys-apps/acl )
+       python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
+       static? (
+               dev-libs/lzo:2[static-libs(+)]
+               sys-apps/util-linux:0[static-libs(+)]
+               sys-libs/zlib:0[static-libs(+)]
+               convert? (
+                       sys-fs/e2fsprogs:0[static-libs(+)]
+                       sys-libs/e2fsprogs-libs:0[static-libs(+)]
+                       reiserfs? (
+                               >=sys-fs/reiserfsprogs-3.6.27[static-libs(+)]
+                       )
+               )
+               zstd? ( app-arch/zstd:0[static-libs(+)] )
+       )
+"
+BDEPEND="
+       >=app-text/asciidoc-8.6.0
+       app-text/docbook-xml-dtd:4.5
+       app-text/xmlto
+"
+
+if [[ ${PV} == 9999 ]]; then
+       DEPEND+=" sys-devel/gnuconfig"
+fi
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+       if [[ ${PV} == 9999 ]]; then
+               AT_M4DIR=m4 eautoreconf
+               mkdir config || die
+               local automakedir="$(autotools_run_tool --at-output automake --print-libdir)"
+               [[ -e ${automakedir} ]] || die "Could not locate automake directory"
+               ln -s "${automakedir}"/install-sh config/install-sh || die
+               ln -s "${EPREFIX}"/usr/share/gnuconfig/config.guess config/config.guess || die
+               ln -s "${EPREFIX}"/usr/share/gnuconfig/config.sub config/config.sub || die
+       fi
+}
+
+src_configure() {
+       local myeconfargs=(
+               --bindir="${EPREFIX}"/sbin
+               $(use_enable convert)
+               $(use_enable elibc_glibc backtrace)
+               $(use_enable python)
+               $(use_enable static-libs static)
+               $(use_enable zstd)
+               --with-convert=ext2$(usex reiserfs ',reiserfs' '')
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       emake V=1 all $(usev static)
+}
+
+src_install() {
+       local makeargs=(
+               $(usex python install_python '')
+               $(usex static install-static '')
+       )
+       emake V=1 DESTDIR="${D}" install "${makeargs[@]}"
+       newbashcomp btrfs-completion btrfs
+       use python && python_optimize
+}