dev-ml/llvm-ocaml: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:33 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:41 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
dev-ml/llvm-ocaml/llvm-ocaml-9.0.1.9999.ebuild

index b0d581bd9ff5ec1d7e0649a3c4e14b985c3e2729..664c0aa44847318637d7b16f75ad1ed5e29d20fe 100644 (file)
@@ -13,8 +13,8 @@ inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
 DESCRIPTION="OCaml bindings for LLVM"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
-       https://github.com/llvm-mirror/llvm.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/llvm
 
 # Keep in sync with sys-devel/llvm
 ALL_LLVM_EXPERIMENTAL_TARGETS=( ARC AVR )
@@ -53,6 +53,11 @@ pkg_setup() {
        python-any-r1_pkg_setup
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' llvm
+}
+
 src_prepare() {
        # Python is needed to run tests using lit
        python_setup
index ea47038cb4437095d1773bba4f5e13aeb1e671e4..d47587faed9b1a8efab41ed93294db4aced3ec07 100644 (file)
@@ -13,9 +13,9 @@ inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
 DESCRIPTION="OCaml bindings for LLVM"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
-       https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/llvm
 
 # Keep in sync with sys-devel/llvm
 ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -52,6 +52,11 @@ pkg_setup() {
        python-any-r1_pkg_setup
 }
 
+src_unpack() {
+       git-r3_fetch
+       git-r3_checkout '' '' '' llvm
+}
+
 src_prepare() {
        # Python is needed to run tests using lit
        python_setup